./archivers/ruby-libarchive, Ruby bindings for Libarchive

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.1.2nb2, Package name: ruby23-libarchive-0.1.2nb2, Maintainer: pkgsrc-users

Libarchive is a programming library that can create and read several
different streaming archive formats, including most popular tar
variants, several cpio formats, and both BSD and GNU ar variants.


Required to run:
[archivers/libarchive] [lang/ruby23-base]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 5a7f5d5e9771f00c4ef2b030602381a29ff0eb11
RMD160: 337296b1c31898ee7e438fd5e368fb821462c341
Filesize: 52.5 KB

Version history: (Expand)


CVS history: (Expand)


   2017-05-29 13:09:46 by Jonathan Perkin | Files touched by this commit (16)
Log message:
Recursive revision bump for archivers/libarchive.
   2016-07-01 19:55:24 by Jonathan Perkin | Files touched by this commit (19) | Package updated
Log message:
The recent libarchive update changed the library major.  Increase the
ABI depends and perform a PKGREVISION bump for dependents.

Noticed by OSX binary package users.
   2016-01-04 03:48:05 by Takahiro Kambe | Files touched by this commit (3)
Log message:
Fix "work-directory references" problem another way.
   2015-11-03 01:56:27 by Alistair G. Crooks | Files touched by this commit (93)
Log message:
Add SHA512 digests for distfiles for archivers category

Problems found with existing distfile for eagle:
	distfiles/bicom101.zip
	distfiles/szip-2.1nb3/szip-2.1.tar.gz
	distfiles/xmill-0.9.1.tar.gz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-09-25 07:45:58 by Takahiro Kambe | Files touched by this commit (1) | Package updated
Log message:
Update HOEPAGE.
Avoid using rubyforge.org since it stopped most of services.
   2015-05-19 15:08:50 by Ryo ONODERA | Files touched by this commit (1)
Log message:
Fix Ruby 2.2 build.
   2015-03-08 16:17:22 by Takahiro Kambe | Files touched by this commit (58) | Package updated
Log message:
Add ${GEM_EXTSDIR}/gem.build_complete for new rubygems and updated ruby.
   2015-01-19 14:26:00 by Takahiro Kambe | Files touched by this commit (1)
Log message:
Fix breakage with ruby21.