./cad/verilog-mode, Verilog mode for Emacs

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 3.60nb3, Package name: verilog-mode-3.60nb3, Maintainer: dmcmahill

This is a major mode for editing Verilog HDL source code under GNU Emacs or
XEmacs.


Required to run:
[editors/emacs24]

Master sites: (Expand)

SHA1: 9fc378eda3cbe9d01beabd2ffa640d27064246f5
RMD160: 459554447a16418ef4aada81721514ccedb2612e
Filesize: 63.674 KB

Version history: (Expand)


CVS history: (Expand)


   2015-11-03 01:21:20 by Alistair G. Crooks | Files touched by this commit (58)
Log message:
Add SHA512 digests for distfiles for cad category

Problems found with existing distfile for eagle:
	distfiles/eagle-lin32-7.4.0.run
No changes made to eagle/distinfo file.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2013-02-17 20:18:11 by David A. Holland | Files touched by this commit (90)
Log message:
Revbump all elisp packages after emacs changes.
   2012-10-08 15:25:17 by Aleksej Saushev | Files touched by this commit (62)
Log message:
Drop PKG_DESTDIR_SUPPORT setting, "user-destdir" is default these days.
   2009-08-06 03:44:57 by Min Sik Kim | Files touched by this commit (67)
Log message:
PKGREVISION bump for elisp packages because of bytecode format changes
in emacs23.
   2008-10-11 11:31:58 by Masao Uebayashi | Files touched by this commit (100)
Log message:
Move mk/emacs.mk to editors/emacs/modules.mk.

Don't call pkg_info to get the installed Emacs version; always use the
version matching EMACS_TYPE set by users.  Be DEPENDS to it.  This should
address pkg/37146 by Aleksey Cheusov.

While here convert some emacs lisp packages to user-destdir.
   2008-03-03 02:50:27 by Johnny C. Lam | Files touched by this commit (16)
Log message:
Mechanical changes to add full DESTDIR support to packages that install
their files via a custom do-install target.
   2006-02-06 00:11:50 by Joerg Sonnenberger | Files touched by this commit (4082)
Log message:
Recursive revision bump / recommended bump for gettext ABI change.
   2005-08-28 06:25:31 by Masao Uebayashi | Files touched by this commit (56)
Log message:
Rework emacs.mk:

1) Simplify the way how an emacs version is picked when no emacs
   is installed, but a user try to install an Emacs Lisp package.
   Just pick up the version set as EMACS_TYPE than searching for
   versions already installed etc.  If the EMACS_TYPE version is
   not supported by the Emacs Lisp Package, just fail.  EMACS_TYPE
   be default to GNU Emacs 21.

   (In other words, users should set EMACS_TYPE as they want.
   Otherwise GNU Emacs 21 is used.)

2) All Emacs Lisp Packages *must* prepend EMACS_PKGNAME_PREFIX to
   a) the PKGNAME itself, and b) PKGNAME in its dependency lines.
   EMACS_PKGNAME_PREFIX is expanded to "xemacs-" when XEmacs is
   used.  This keeps dependency graph of Emacs-Lisp-packages-
   installed-for-XEmacs consistent.

3) Document EMACS_* variables as much as possible.

4) Provide more cookies for PLIST.  Maybe utilized later.

Note that the 2) change doesn't affect the default, GNU Emacs 21
behaviour.  So no version / revision bumps in this commit.