./chat/anope, Modular set of IRC services

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.0.7, Package name: anope-2.0.7, Maintainer: nia

Anope is an open source set of IRC Services. It is highly modular,
with a vast number of configurable parameters, and is the most used
IRC services package. There are also many modules on the modsite
to add additional features. It supports many modern IRCds, including
InspIRCd, UnrealIRCd, and ircd-hybrid.


Required to run:
[security/gnutls]

Required to build:
[pkgtools/cwrappers]

Package options: gnutls

Master sites:

SHA1: 298c21edbff18a1d3cc711bf84b55ac06ae10d6b
RMD160: fdbc31d1bcd902eddc35efbae871af2b0dddc88b
Filesize: 1774.887 KB

Version history: (Expand)


CVS history: (Expand)


   2019-12-08 04:55:05 by Nia Alarie | Files touched by this commit (6) | Package updated
Log message:
anope: Update to 2.0.7

The notable changes includes:

Fix not sending login data on successful NickServ GROUP
Fix m_httpd to not consider headers to be case sensitive
Add InspIRCd 3 protocol support
Add 'n' email token for use in the email change template
Add logging for NickServ UNGROUP
Fix setting swhois on UnrealIRCd
Add nickserv/recover permission to allow opers to recover other users
Fix superadmin not being removed when deopering
Fix setting nickserv access list in webcpanel
Add support for post-handshake SASL in Unreal 4.2.2+
Add logging for channel memo deletionso
   2019-07-21 00:46:59 by Thomas Klausner | Files touched by this commit (595)
Log message:
*: recursive bump for nettle 3.5.1
   2019-05-23 21:23:24 by Roland Illig | Files touched by this commit (242)
Log message:
all: replace SUBST_SED with the simpler SUBST_VARS

pkglint -Wall -r --only "substitution command" -F

With manual review and indentation fixes since pkglint doesn't get that
part correct in every case.
   2019-05-03 13:05:11 by Nia Alarie | Files touched by this commit (2)
Log message:
chat/anope: Use gettext-lib and msgfmt. Default to gnutls over openssl.

Without gettext-lib and msgfmt being available, package creation fails
because the locale files aren't generated.

Similar reasoning for gnutls as inspircd - anope is based on an old
version of inspircd and is also GPLv2 with no exception for OpenSSL.
gnutls is the recommended TLS library for both.
   2019-04-07 21:30:13 by Thomas Klausner | Files touched by this commit (1)
Log message:
anope: fix DISTNAME.
   2019-04-03 02:33:20 by Ryo ONODERA | Files touched by this commit (748)
Log message:
Recursive revbump from textproc/icu
   2019-02-05 20:10:50 by Nia Alarie | Files touched by this commit (15) | Package removed
Log message:
chat/anope: Update to 2.0.6

[10 years of updates, no changelog. Based on work in pkgsrc-wip.]
   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0