./chat/farstream, Audio/video communications framework

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.2.8nb2, Package name: farstream-0.2.8nb2, Maintainer: pkgsrc-users

The Farstream (formerly Farsight) project is an effort to create
a framework to deal with all known audio/video conferencing protocols.
On one side it offers a generic API that makes it possible to write
plugins for different streaming protocols, on the other side it
offers an API for clients to use those plugins.

The main target clients for Farstream are Instant Messaging
applications. These applications should be able to use Farstream
for all their Audio/Video conferencing needs without having to
worry about any of the lower level streaming and NAT traversal
issues.

Farstream forms an integral part of the Telepathy framework. It is
used by Empathy through the Telepathy-Farstream library. The
Telepathy-Farstream library binds it to the Connection Managers
via D-Bus and the Telepathy Media Stream Spec and is used for all
their streaming requirements.


Required to run:
[devel/glib2] [net/gupnp-igd] [net/libnice] [multimedia/gstreamer1] [multimedia/gst-plugins1-base]

Required to build:
[textproc/gtk-doc] [pkgtools/cwrappers]

Master sites:

SHA1: e6d9388aaf44e06b7cb4e0297a8e4c53fe16be63
RMD160: 47392a6461a948d324bf896b0dab33289ed1cfbf
Filesize: 1284.715 KB

Version history: (Expand)


CVS history: (Expand)


   2016-12-04 06:17:46 by Ryo ONODERA | Files touched by this commit (667)
Log message:
Recursive revbump from textproc/icu 58.1
   2016-05-03 13:40:11 by Patrick Welche | Files touched by this commit (169)
Log message:
revbump for libsoup's ABI issue
   2016-04-15 11:07:40 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Update farstream to 0.2.8.

farstream 0.2.8 (March 10, 2016)
==================================
- Add "require-encryption" parameter to ignore unencrypted packets
- Enable building static GStreamer and transmitter plugins
- Make OPUS plugin work and select it as default codec
- Bug fixes
   2016-04-11 21:02:08 by Ryo ONODERA | Files touched by this commit (527)
Log message:
Recursive revbump from textproc/icu 57.1
   2015-12-01 13:59:52 by Jaap Boender | Files touched by this commit (5)
Log message:
Added package farstream, version 0.2.7---an audio/video communications
framework. Based on the farstream package from pkgsrc-wip.