./chat/p5-POE-Component-IRC, Fully event-driven IRC client module

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 6.88nb2, Package name: p5-POE-Component-IRC-6.88nb2, Maintainer: pkgsrc-users

POE::Component::IRC is a POE component (who'd have guessed?) which acts as an
easily controllable IRC client for your other POE components and sessions.
You create an IRC component and tell it what events your session cares about
and where to connect to, and it sends back interesting IRC events when they
happen. You make the client do things by sending it events.


Required to run:
[chat/p5-POE-Filter-IRCD] [lang/perl5] [devel/p5-POE] [devel/p5-Test-Differences] [devel/p5-POE-Component-Syndicator] [chat/p5-IRC-Utils]

Master sites: (Expand)

SHA1: fa4b8b1d4170fe14ea441c50dec1f77639e396b8
RMD160: c6f936c4b0acc1ca923b7429f918c12160d22060
Filesize: 385.131 KB

Version history: (Expand)


CVS history: (Expand)


   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2015-11-03 02:20:26 by Alistair G. Crooks | Files touched by this commit (119)
Log message:
Add SHA512 digests for distfiles for chat category

Problems found with existing distfiles:
	distfiles/icb-5.0.9.tar.gz
	distfiles/icb.2.1.4.tar.Z
	distfiles/zenicb-19981202.tar.gz
No changes made to these /distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2014-12-03 07:41:13 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 6.88

Upstream changes:
6.88  Sat Jun 28 13:14:00 BST 2014
    - BotAddressed: Handle being addressed with a prefixed @ or %

6.87  Sat Jun 21 15:08:32 BST 2014
    - Believe have resolved issues with online test

6.86  Fri Jun 20 11:12:06 BST 2014
    - Added more diagnostics to the online test

6.85  Thu Jun 19 10:19:07 BST 2014
    - Added some diagnostics output to the online test

6.84  Tue Jun 17 10:45:38 BST 2014
    - Plugman: store @$ or else it gets overwritten - Commit: 65ba2a4f3
   2014-10-09 16:07:17 by Thomas Klausner | Files touched by this commit (1163)
Log message:
Remove pkgviews: don't set PKG_INSTALLATION_TYPES in Makefiles.
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.
   2013-12-15 14:43:57 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 6.83
Update DEPENDS

Upstream changes:
6.83  Mon May 27 10:40:09 BST 2013
    - NickServID: React on IRC Message 433 - Commit: ec7cd33736
    - BotCommand: Support for overriding the Command Handler
    - BotCommand: Added Support for a Help Modification Callback
    - BotCommand: Adapted the Help Callback Options so it gets the Command and \ 
Arguments
    - BotCommand: Added Support for Command Aliases
    - BotCommand: Allowed No Arguments/Only Variable Arguments
    - Implemented SSL Client Cert Support

6.82  Sat Mar 9 22:15:02 GMT 2013
    - Add the Prefix to the "Syntax:" line of the command help

6.81  Fri Nov 23 15:53:11 GMT 2012
    - Resolve hash randomisation issues with v5.17.6

6.80  Thu Sep 20 09:52:59 BST 2012
    - Add missing prereq

6.79  Wed Sep 19 14:24:03 BST 2012
    - Argument naming and argument count validation in Plugin::BotCommand
    - [rt.cpan.org #79745] nick_long_form dies due to a race condition
   2013-05-31 14:42:58 by Thomas Klausner | Files touched by this commit (2880)
Log message:
Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.