./comms/lirc, Linux Infrared Remote Control

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.9.0nb3, Package name: lirc-0.9.0nb3, Maintainer: cheusov

LIRC is a package that supports receiving and sending IR signals of
the most common IR remote controls. It contains a daemon that decodes
and sends IR signals, a mouse daemon that translates IR signals to
mouse movements and a couple of user programs that allow to control
your computer with a remote control.


Required to run:
[devel/libusb-compat]

Required to build:
[pkgtools/x11-links] [pkgtools/cwrappers]

Package options: x11

Master sites:

SHA1: 8456bf7101d4f2d31d61c5073357a4981b458581
RMD160: d8f1cf3a03573be36787e87adc71beba3e678a37
Filesize: 837.193 KB

Version history: (Expand)


CVS history: (Expand)


   2018-02-28 00:56:10 by Pierre Pronchery | Files touched by this commit (25)
Log message:
Revbump for packages depending on devel/libusb{,compat}
   2018-02-10 14:53:49 by Pierre Pronchery | Files touched by this commit (39)
Log message:
Import global switch for libusb's implementation [2/2]

This switch is meant to be used by packages requiring an implementation of the
former libusb (as in devel/libusb). The original implementation can be
chosen by setting LIBUSB_TYPE to "native".

The alternative implementation libusb-compat (as in devel/libusb-compat) wraps
libusb1 (in devel/libusb1). This implementation can be chosen by setting
LIBUSB_TYPE to "compat". On NetBSD, it has the advantage of not \ 
requiring root
privileges to locate and use USB devices without a kernel driver.

This second part switches packages using libusb to this framework. It does not
change compilation options or dependencies at this point.

Compile-tested on most packages affected and available on NetBSD/amd64.
   2016-05-02 04:32:14 by David A. Holland | Files touched by this commit (7) | Package updated
Log message:
PR 50556: comms/lirc doesn't build
Add patches to work around gcc inline mess.

Note: this package should be updated and the PR contains an update, but
I don't want to do that when I can't compile it (whereas simple mechanical
patches are much less likely to go astray...)
   2016-04-11 06:22:35 by Darrin B. Jewell | Files touched by this commit (11) | Package updated
Log message:
update PKG_{FAIL,SKIP}_REASON with +=
   2015-11-03 02:34:58 by Alistair G. Crooks | Files touched by this commit (79)
Log message:
Add SHA512 digests for distfiles for comms category

Existing SHA1 digests verified, all found to be the same on the
machine holding the existing distfiles (morden).  Existing SHA1
digests retained for now as an audit trail.
   2015-01-01 10:35:17 by David A. Holland | Files touched by this commit (1)
Log message:
Use PKG_SKIP_REASON for unsupported OSes.
   2014-03-11 15:05:19 by Jonathan Perkin | Files touched by this commit (350)
Log message:
Remove example rc.d scripts from PLISTs.

These are now handled dynamically if INIT_SYSTEM is set to "rc.d", or
ignored otherwise.
   2012-12-25 12:41:25 by Aleksey Cheusov | Files touched by this commit (1)
Log message:
Fix build failure on some Linuxes if CHECK_INTERPRETER=yes