./converters/libwpd, Library for importing and exporting WordPerfect(tm) documents

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.10.1nb2, Package name: libwpd-0.10.1nb2, Maintainer: jaapb

libwpd is a library for reading and writing WordPerfect(tm)
documents.

This package also includes utilities for converting to HTML
and plain text.


Required to run:
[converters/librevenge]

Required to build:
[devel/boost-headers] [pkgtools/cwrappers]

Master sites:

SHA1: 6c0a8a68a21e3b644ca20281d96b1e4069cd78a5
RMD160: f1b230c19238aa70b04c4a90886f882489b28a04
Filesize: 641.461 KB

Version history: (Expand)


CVS history: (Expand)


   2017-01-01 17:06:40 by Adam Ciarcinski | Files touched by this commit (616) | Package updated
Log message:
Revbump after boost update
   2016-10-07 20:26:14 by Adam Ciarcinski | Files touched by this commit (611) | Package updated
Log message:
Revbump post boost update
   2016-03-08 19:58:06 by Ryo ONODERA | Files touched by this commit (2) | Package updated
Log message:
Update to 0.10.1

Changelog:
0.10.0 - 0.10.1
- Fix crash when NULL is passed as input stream.
- Use symbol visibility on Linux. The library only exports public functions
  now.
- Avoid infinite loop. (libwpd#3)
- Remove bashism. (libwpd#5)
- Fix various crashes and hangs when reading broken files found with the
  help of american-fuzzy-lop.
- Make --help output of all command line tools more help2man-friendly.
- Miscellaneous fixes and cleanups.
   2015-11-03 02:43:56 by Alistair G. Crooks | Files touched by this commit (120)
Log message:
Add SHA512 digests for distfiles for converters category

Problems found with existing distfile:
	distfiles/libiconv-1.13-cp932.patch.gz
No changes made to the libiconv distinfo file.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-09-14 05:07:12 by David Sainty | Files touched by this commit (1)
Log message:
Include all buildlink3.mk before compiler.mk, as the buildlink dependencies
may alter the compiler selection.

In this particular case, librevenge depends on boost-libs, which will
set GCC_REQD and possibly select a GCC dependency, so long as the compiler
hasn't been forcibly pre-selected by including compiler.mk too early.

Fixes build of libwpd on platforms with a native GCC older than what
boost-libs calls for.
   2015-08-16 00:46:40 by Thomas Klausner | Files touched by this commit (33) | Package updated
Log message:
Bump PKGREVISION for librevenge boost fix.
   2014-12-01 13:39:18 by Joerg Sonnenberger | Files touched by this commit (24)
Log message:
Support cwrappers for packages appending arguments in the wrappers.
   2014-07-22 12:55:14 by Thomas Klausner | Files touched by this commit (1)
Log message:
Fix scripto.