./devel/glib2-tools, GLib2/gobject python-dependent tools

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.54.2, Package name: glib2-tools-2.54.2, Maintainer: prlw1

This package provides glib2/gobject's python dependent tools:
glib-mkenums and glib-genmarshal.


Master sites: (Expand)

SHA1: 85b5d649fc3d18f8d8197bd971dfbebd94b5f96d
RMD160: 6804848c49bc882da563d8c3e025f1e37518bbc5
Filesize: 7647.191 KB

Version history: (Expand)


CVS history: (Expand)


   2017-11-07 16:53:11 by Patrick Welche | Files touched by this commit (2) | Package updated
Log message:
glib2-tools: remove pkgrevision as adam updated glib2
   2017-10-21 10:57:33 by Patrick Welche | Files touched by this commit (3)
Log message:
glib2-tools: Handle source files which are not utf-8

python 3 is strict about file encodings. After glib-mkenums was
translated from perl to python, build failures occur due to e.g.,
ISO-8859-1 characters in authors' names as reported by martin@ in
PR pkg/52631 for xfce4-gtk2-engines, but also causing build failures
for at least libgnome and libgnomeui.

Chritoph Reiter produced an elegant workaround, making use of the
open() function's error decoding "replace" option:

  'replace' causes a replacement marker (such as '?') to be inserted
  where there is malformed data.

which is applied here.

https://bugzilla.gnome.org/show_bug.cgi?id=785113#c27
   2017-10-15 16:10:40 by Patrick Welche | Files touched by this commit (3)
Log message:
Add glib2-tools, a place for glib2/gobject's python dependent tools,
namely glib-genmarshal and glib-mkenums.