./devel/gnustep-base, GNUstep foundation classes

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.24.0nb15, Package name: gnustep-base-1.24.0nb15, Maintainer: pkgsrc-users

The GNUstep Base Library is a library of general-purpose, non-graphical
Objective C objects. For example, it includes classes for strings,
object collections, byte streams, typed coders, invocations,
notifications, notification dispatchers, moments in time, network ports,
remote object messaging support (distributed objects), and event loops.

It provides functionality that aims to implement the non-graphical
portion of the OpenStep standard (the Foundation library).


Required to run:
[textproc/libxml2] [textproc/libxslt] [textproc/icu] [security/gnutls] [devel/gmp] [devel/libffi] [devel/gnustep-make] [devel/gnustep-objc] [lang/clang]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 4d73df5b5a594213a4c7a0ed97fc04d10c9ced69
RMD160: 3710966cac708c5f22b1e5eaee456951791a1620
Filesize: 2878.671 KB

Version history: (Expand)


CVS history: (Expand)


   2017-04-22 23:04:05 by Adam Ciarcinski | Files touched by this commit (670) | Package updated
Log message:
Revbump after icu update
   2016-12-04 06:17:46 by Ryo ONODERA | Files touched by this commit (667)
Log message:
Recursive revbump from textproc/icu 58.1
   2016-11-23 16:56:03 by Sebastian Wiedenroth | Files touched by this commit (1)
Log message:
also needs openssl for HTTPS connections in NSURL
   2016-09-19 15:04:29 by Thomas Klausner | Files touched by this commit (147)
Log message:
Recursive PKGREVISION bump for gnutls shlib major bump.
   2016-04-11 21:02:08 by Ryo ONODERA | Files touched by this commit (527)
Log message:
Recursive revbump from textproc/icu 57.1
   2016-04-03 22:23:26 by Joerg Sonnenberger | Files touched by this commit (2)
Log message:
When trying to test for OpenSSL, pick a function that has a chance of
existing in modern versions.
   2015-12-30 00:09:35 by Benny Siegert | Files touched by this commit (3) | Package updated
Log message:
Add a patch for CVS-2014-2980: Tools/gdomap.c in gdomap in GNUstep Base 1.24.6
and earlier, when run in daemon mode, does not properly handle the file
descriptor for the logger, which allows remote attackers to cause a denial of
service (abort) via an invalid request.

Bump pkgrevision.
   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.