./devel/libextractor, Metadata extractor for various file data types

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.9nb4, Package name: libextractor-1.9nb4, Maintainer: pkgsrc-users

libextractor is a simple library for keyword extraction. libextractor
does not support all formats but supports a simple plugging mechanism
such that you can quickly add extractors for additional formats, even
without recompiling libextractor. libextractor typically ships with a
dozen helper-libraries that can be used to obtain keywords from common
file-types.


Required to run:
[www/tidy] [graphics/ImageMagick] [graphics/exiv2] [graphics/tiff] [multimedia/libmpeg2] [archivers/libarchive] [audio/flac] [audio/libvorbis] [devel/libgsf] [devel/libltdl] [x11/gtk3] [audio/libsmf] [multimedia/mp4v2]

Required to build:
[pkgtools/x11-links] [x11/xcb-proto] [x11/fixesproto4] [pkgtools/cwrappers] [x11/xorgproto]

Master sites: (Expand)

SHA1: d66e54e51cd97814d55f07825ea1bfdf93d67fea
RMD160: 629ae88a017db0b3ab7f645742ba98c2ea05d9e4
Filesize: 8128.762 KB

Version history: (Expand)


CVS history: (Expand)


   2019-08-23 13:06:08 by ng0 | Files touched by this commit (2)
Log message:
devel/libextractor: Fix pkglint for patch file.
   2019-08-23 13:02:30 by ng0 | Files touched by this commit (3)
Log message:
devel/libextractor: Add patch to fix build with exiv2, revbump
   2019-07-22 00:26:08 by Thomas Klausner | Files touched by this commit (1256)
Log message:
*: recursive bump for gdk-pixbuf2-2.38.1
   2019-07-17 03:03:38 by Nia Alarie | Files touched by this commit (1)
Log message:
libextractor: needs openssl for -lcrypto
   2019-07-17 02:51:07 by Nia Alarie | Files touched by this commit (37) | Package updated
Log message:
Recursive revbump for graphics/exiv2 update.
   2019-07-08 17:25:13 by Nia Alarie | Files touched by this commit (1)
Log message:
libextractor: Pulls in libmagic, so explicitly depend on sysutils/file.
   2019-07-08 17:02:42 by Nia Alarie | Files touched by this commit (1)
Log message:
libextractor: Fix various dependencies.

- Add msgfmt msgmerge xgettext to USE_TOOLS, it needs these
- Fix building with libjpeg-turbo by using the correct buildlink
- Use newer multimedia/mp4v2 over multimedia/libmp4v2 to avoid conflicts
  This is confusing. I think we mainly keep libmp4v2 around for KDE4.
  But the packages could be named better.
   2019-02-19 01:09:21 by Greg Troxel | Files touched by this commit (2) | Package updated
Log message:
libextrator: Update to libextractor-1.9 (from ng0 via wip)

upstream changes:
* CVEs fixed in or before version 1.9: CVE-2018-20430, CVE-2018-20431, \ 
CVE-2017-15922, CVE-2017-17440
* upstream ChangeLog:
Sun 10 Feb 2019 05:05:22 PM CET
	Added Danish translation.
	Releasing GNU libextractor 1.9. -CG

Thu Dec 20 22:48:47 CET 2018
	Fix #5493: possible out-of-bounds read in libextractor_common
	in case of iconv() failure.
	Fix #5494: NULL dereference in OLE2 extractor (for malformed input). -CG

Sun Dec  2 12:05:33 CET 2018
	Fix #5488: do not export non-public functions from API. -CG