./devel/ocaml-ppx_tools_versioned, Tools for authors of ppx rewriters

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 5.2, Package name: ocaml-ppx_tools_versioned-5.2, Maintainer: jaapb

Tools for authors of syntactic tools (such as ppx rewriters). This particular
version works with different versions of OCaml.


Required to run:
[lang/ocaml] [devel/ocaml-findlib] [devel/ocaml-jbuilder] [devel/ocaml-migrate-parsetree]

Required to build:
[pkgtools/cwrappers] [misc/ocaml-opaline]

Master sites:

SHA1: 42f73c7ea3d2871fda2d24078327a0601d637a40
RMD160: b895bc0de431446561ec1d8e52df5ba24097b8ef
Filesize: 51.446 KB

Version history: (Expand)


CVS history: (Expand)


   2018-07-19 15:01:34 by Jaap Boender | Files touched by this commit (4) | Package updated
Log message:
Updated devel/ocaml-ppx_tools_versioned to version 5.2.

There does not seem to be a changelog available, but this version adds
support for OCaml 4.07 and now uses the jbuilder build system.
   2018-04-13 15:55:39 by Jaap Boender | Files touched by this commit (88)
Log message:
Revbump associated with the upgrade of lang/ocaml

(this is the upgrade from 4.06 to 4.06.1)
   2018-01-10 17:53:15 by Jaap Boender | Files touched by this commit (107) | Package updated
Log message:
Recursive revbump associated with the update to OCaml 4.06.
   2018-01-07 14:04:44 by Roland Illig | Files touched by this commit (583)
Log message:
Fix indentation in buildlink3.mk files.

The actual fix as been done by "pkglint -F */*/buildlink3.mk", and was
reviewed manually.

There are some .include lines that still are indented with zero spaces
although the surrounding .if is indented. This is existing practice.
   2017-09-08 11:51:27 by Jaap Boender | Files touched by this commit (113) | Package updated
Log message:
Recursive revbump associated with update of ocaml to 4.05
   2017-07-23 16:42:08 by Jaap Boender | Files touched by this commit (5)
Log message:
Added package devel/ocaml-ppx_tools_versioned, a version of ppx_tools that
works with different versions of OCaml. Needed as a dependency.