./devel/p5-Carp-Clan, Report errors from perspective of a clan of modules

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 6.07, Package name: p5-Carp-Clan-6.07, Maintainer: pkgsrc-users

This module reports errors from the perspective of the caller of a
"clan" of modules, similar to "Carp.pm" itself. But instead of giving it
a number of levels to skip on the calling stack, you give it a pattern
to characterize the package names of the "clan" of modules which shall
never be blamed for any error. :-)

So these modules stick together like a "clan" and any error which occurs
will be blamed on the "outsider" script or modules not belonging to this
"clan".


Required to run:
[lang/perl5]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

SHA1: 55247ca5e0db1b3458495c852cb43388be3432af
RMD160: d4b66b7251d8348dca2f8905c207fc015c795338
Filesize: 33.013 KB

Version history: (Expand)


CVS history: (Expand)


   2018-12-31 10:18:44 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 6.07

Upstream changes:
6.07      2018-12-02 21:44:55Z
 - declared test prerequisites in the proper phase (RT#125288)
 - modernized distribution tooling
   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0
   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2016-06-05 11:46:59 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-Carp-Clan to 6.06
----------------------------------
Version 6.06  29.05.2016
 + Avoid failure due to version self-check in 20pre560.t
   This test seems like a footgun for release management reasons, but apprently
   I wasn't quite as careful as I tried to be in keeping the last release minimal.

Version 6.05  29.05.2016
 + Patch tests failing due to 5.25.1+'s deprecated unquoted { } in regex.
   (RT #114537)
   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2014-10-09 16:07:17 by Thomas Klausner | Files touched by this commit (1163)
Log message:
Remove pkgviews: don't set PKG_INSTALLATION_TYPES in Makefiles.