./devel/p5-Clone-PP, Recursively copy Perl datatypes

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.06nb2, Package name: p5-Clone-PP-1.06nb2, Maintainer: pkgsrc-users

This module provides a general-purpose clone function to make deep
copies of Perl data structures. It calls itself recursively to copy
nested hash, array, scalar and reference types, including tied
variables and objects.

The clone() function takes a scalar argument to copy. To duplicate
arrays or hashes, pass them in by reference:

The clone() function also accepts an optional second parameter that
can be used to limit the depth of the copy. If you pass a limit of
0, clone will return the same value you supplied; for a limit of
1, a shallow copy is constructed; for a limit of 2, two layers of
copying are done, and so on.


Required to run:
[lang/perl5]

Master sites: (Expand)

SHA1: a84e7f517e2279456f1651bbf84e349494fb58f4
RMD160: 4363212f56fd75fa45763837e2e6be36d3cc4ae8
Filesize: 9.156 KB

Version history: (Expand)


CVS history: (Expand)


   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2014-09-06 15:32:10 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Update to 1.06:

1.06 2014-07-20 NEILB
    - Changed the copyright on dclone.t, dump.pl, and tied.pl in t/,
      to match the rest of the dist, "same as perl itself".
      These changes were approved by the copyright owner, Raphael Manfredi.

1.05 2014-02-17 NEILB
    - Added github repo to metadata (thanks dsteinbrunner)
    - Added github repo to doc

1.04 2014-02-17 NEILB
    - I had erroneously listed Test::Array as a test prereq,
      but the package is defined in 01array.t where it's used.
      RT#93082 - thanks to Dagfinn Ilmari Mannsaker.

1.03 2014-02-16 NEILB
    - Added Changes file
    - Fixed typos from dsteinbrunner in RT#86337
    - Added "use warnings" and in the process fixed RT#17121
    - Min perl version 5.6.0 in code and metadata
    - Added license type to metadata and renamed L&C section in pod
    - Expanded the SEE ALSO section
    - Added prereqs to PREREQ_PM in Makefile.PL
    - Added test prereqs in TEST_REQUIRES
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.
   2013-05-31 14:42:58 by Thomas Klausner | Files touched by this commit (2880)
Log message:
Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.
   2012-10-31 12:19:55 by Aleksej Saushev | Files touched by this commit (1460)
Log message:
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
   2012-10-03 23:59:10 by Thomas Klausner | Files touched by this commit (2798)
Log message:
Bump all packages that use perl, or depend on a p5-* package, or
are called p5-*.

I hope that's all of them.