./devel/p5-Contextual-Return, Perl 5 module to create context-senstive return values

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.004.014, Package name: p5-Contextual-Return-0.004.014, Maintainer: pkgsrc-users

The Perl 5 module Contextual::Return provides a collection of named
blocks that allow a return statement to return different values
depending on the context in which it's called.


Required to run:
[lang/perl5] [devel/p5-Want]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

SHA1: 3c3c507d4cad3f394771a80ba36c5b998aca1f52
RMD160: 17d260106d30eec4e2d8223b2b811256a7c8e899
Filesize: 40.066 KB

Version history: (Expand)


CVS history: (Expand)


   2017-04-21 16:30:37 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-Contextual-Return to 0.004014
----------------------------------------------
0.004014  Fri Apr 14 18:46:16 2017
    - Reverted to 0.004011 due to segfaults under
      optimized memory leak patch (thanks, Slavin!)
   2017-04-14 17:03:20 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-Contextual-Return to 0.004012
----------------------------------------------
0.004012  Thu Apr 13 01:06:09 2017

    - Optimized previous patch for memory leak
      (thanks, Jay and Father C.)

    - Added missing test plan to t/fail.t
   2017-04-09 13:45:51 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-Contextual-Return to 0.004011
----------------------------------------------
0.004011  Sat Apr  8 15:23:14 2017
    - Patched memory leak from use of @DB::args
      (thanks, Jay!)
   2016-12-16 13:53:06 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-Contextual-Return to 0.004.010
-----------------------------------------------
0.004009  Fri Nov 18 08:34:19 2016
    - Improved behaviour of FREEZE (Thanks, Mathew!)
    - Improved output of DUMP

0.004010  Thu Dec  1 17:41:14 2016
    - Spelling fix in POD (thanks, Salvatore)
    - Improved DUMP behaviour when passed a non-CRV argument
      (thanks, Mathew)
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2016-04-09 16:18:48 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Update to p5-Contextual-Return-0.004.008
----------------------------------------
0.004008  Sat Sep 12 13:16:30 2015

    - Promoted $VERSION variable to earlier in source to
      attempt to placate cpanminus (thanks, Karen!)

    - Added prototype to overridden caller()

    - Changed way caller() is overridden, hopefully will no longer
      clash with Sub::Uplevel
   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-07-12 20:56:37 by Thomas Klausner | Files touched by this commit (405)
Log message:
Comment out dependencies of the style
{perl>=5.16.6,p5-ExtUtils-ParseXS>=3.15}:../../devel/p5-ExtUtils-ParseXS
since pkgsrc enforces the newest perl version anyway, so they
should always pick perl, but sometimes (pkg_add) don't due to the
design of the {,} syntax.

No effective change for the above reason.

Ok joerg