./devel/p5-Devel-Cover, Perl 5 module providing code coverage metrics

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.24, Package name: p5-Devel-Cover-1.24, Maintainer: pkgsrc-users

The Perl 5 module Devel::Cover provides code coverage metrics for
Perl. Code coverage metrics describe how thoroughly tests exercise
code. By using Devel::Cover you can discover areas of code not
exercised by your tests and determine which tests to create to
increase coverage. Code coverage can be considered as an indirect
measure of quality.


Required to run:
[textproc/p5-Pod-Coverage] [www/p5-Template-Toolkit] [lang/perl5] [devel/p5-Perl-Tidy] [textproc/p5-PPI-HTML]

Required to build:
[devel/p5-Test-Differences] [pkgtools/cwrappers]

Master sites: (Expand)

SHA1: 06766c571342aad6689b5b668716f12c5edddde2
RMD160: 5048b3292d3750c2175a2659e9afe66709c02ec3
Filesize: 197.836 KB

Version history: (Expand)


CVS history: (Expand)


   2017-04-22 08:35:28 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-Devel-Cover to 1.24
------------------------------------
Release 1.24 - 18 April 2017
 - Work with 5.25.x (op_sibling) (Dan Collins, Matthew Horsfall) (github 162).
 - Perl versions below 5.10.0 are now unsupported.
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2016-04-25 16:36:30 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated to devel/p5-Devel-Cover-1.23
------------------------------------
Release 1.23 - 24 April 2016
 - Enhance html coverage popups (Haydn Newport) (guthub 156).
 - Add cpamcover about page (Guillermo O. Freschi) (github 146).
 - Perl versions below 5.8.1 are now unsupported.
   2016-04-10 04:12:47 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Update to devel/p5-Devel-Cover-1.22
-----------------------------------
Release 1.22 - 9 April 2016
 - Test against 5.20.3, 5.21.1 - 5.21.9, 5.22.1.
 - Improve uncoverable docs (Alex Balhatchet) (github 148).
 - Improve cpancover.
   2016-01-23 09:49:48 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 1.21

Upstream changes:
Release 1.21 - 20 September 2015
 - Test more versions on travis.
 - Fix things up with cpancover for new docker release.
 - Fix problem under 5.22 (Dick Franks) (github 140).
   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-08-03 09:44:48 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 1.20

Upstream changes:
Release 1.20 - 6 July 2015
 - Document setting PerlSwitches for mod_perl (jpsalvesen) (github 128).

Release 1.19 - 5 July 2015
 - Get things working with 5.22.0.
 - Test against 5.23.0.
 - Remove dependency on Test::Warn.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.