./devel/p5-Devel-OverrideGlobalRequire, Perl 5 package that overrides CORE::GLOBAL::require safely

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.001, Package name: p5-Devel-OverrideGlobalRequire-0.001, Maintainer: pkgsrc-users

This perl module overrides CORE::GLOBAL::require with a code reference
in a way that plays nice with any existing overloading and ensures
the right calling package is in scope.


Required to run:
[lang/perl5]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: ac6c0108c0f73dc95600e494ff9f3ddf0335e97b
RMD160: cd91e85b02eeb4dd0c2f388aa3632c13f370bb24
Filesize: 14.016 KB

Version history: (Expand)


CVS history: (Expand)


   2017-09-17 11:29:55 by Thomas Klausner | Files touched by this commit (3)
Log message:
devel/p5-Devel-OverrideGlobalRequire: import version 0.001

This perl module overrides CORE::GLOBAL::require with a code reference
in a way that plays nice with any existing overloading and ensures
the right calling package is in scope.