./devel/p5-ExtUtils-Command, Perl 5 functions to replace common UNIX commands in Makefiles

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.20nb3, Package name: p5-ExtUtils-Command-1.20nb3, Maintainer: pkgsrc-users

The Perl 5 module ExtUtils::Command is used to replace common UNIX
commands. In all cases the provided functions work from @ARGV rather
than taking arguments. This makes them easier to deal with in
Makefiles. Call them like this:
perl -MExtUtils::Command -e some_command some files to work on
The module Shell::Command is also included in this package: it
provides the same functions but take arguments normally.


Required to run:
[lang/perl5]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

SHA1: b37647cb4437a1eb3c6a7be751eb9d415d4077ce
RMD160: a8531a0e66206bf859831529d4a123a775c565b8
Filesize: 20.623 KB

Version history: (Expand)


CVS history: (Expand)


   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2015-01-29 13:20:10 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Update 1.18 to 1.20
-------------------
1.20  Thu, Jan 8, 2015
  - Skip some tests on Haiku as well

1.19  Sat, Dec 27, 2014
  - Late load required modules
   2014-07-15 22:50:23 by Amitai Schlair | Files touched by this commit (2) | Package updated
Log message:
Update to 1.18. From the changelog:

- Remove obsolete VOS special cases from eu_command.t.
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.
   2013-05-31 14:42:58 by Thomas Klausner | Files touched by this commit (2880)
Log message:
Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.