./devel/p5-Git-CPAN-Patch, Patch CPAN modules using Git

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.3.1, Package name: p5-Git-CPAN-Patch-2.3.1, Maintainer: pkgsrc-users

The Perl 5 module Git::CPAN::Patch provides a suite of git commands
aimed at making trivially easy the process of grabbing any distribution
off CPAN, stuffing it in a local git repository and, once gleeful
hacking has been perpetrated, sending back patches to its maintainer.


Required to run:
[www/p5-libwww] [lang/perl5] [time/p5-DateTime-Format-W3CDTF] [devel/p5-File-chdir] [sysutils/p5-File-chmod] [devel/p5-Test-MockObject] [devel/p5-CLASS] [devel/p5-Moose] [archivers/p5-Archive-Any] [devel/p5-Method-Signatures-Simple] [devel/p5-MooseX-SemiAffordanceAccessor] [devel/p5-MooseX-App-Cmd] [devel/p5-BackPAN-Index] [devel/p5-MetaCPAN-API] [devel/p5-Git-Repository] [devel/p5-CPAN-ParseDistribution] [devel/p5-MooseX-App] [devel/p5-MooseX-Role-Tempdir] [devel/p5-CPANPLUS] [devel/p5-Git-Repository-Plugin-AUTOLOAD] [devel/p5-List-Pairwise]

Required to build:
[devel/p5-Devel-CheckOS] [devel/p5-Parallel-ForkManager] [devel/p5-Package-Constants] [devel/p5-Package-DeprecationManager] [textproc/p5-Pod-Elemental] [filesystems/p5-Path-Tiny] [devel/p5-Data-Printer] [devel/p5-Type-Tiny] [pkgtools/cwrappers] [devel/p5-MetaCPAN-Client] [devel/p5-Search-Elasticsearch]

Master sites: (Expand)

SHA1: 5c105809a82ab33fc0912dd6a904a44e7a71ab0f
RMD160: 37ea5fec8ab1f851175cb2921bafe1bf58cf724d
Filesize: 58.33 KB

Version history: (Expand)


CVS history: (Expand)


   2017-04-19 14:12:55 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-Git-CPAN-Patch to 2.3.1
----------------------------------------
2.3.1 2017-01-12
  [ BUG FIXES ]
    - Remove dependency on MooseX::Role::Tempdir. (GH#33, Sebastien
      Deseille)
  [ STATISTICS ]
    - code churn: 3 files changed, 32 insertions(+), 14 deletions(-)
(pkgsrc changes)
 - Add following line for make test
 BUILD_DEPENDS+= \ 
p5-Package-DeprecationManager-[0-9]*:../../devel/p5-Package-DeprecationManager
 - make test situation is the same as 2.3.0 (denoted in commit log)
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2016-04-29 13:48:53 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated to devel/p5-Git-CPAN-Patch-2.3.0
----------------------------------------
  (make test may fail on t/clone.t, but at least perl t/clone.t runs fine,
   I presume it is not on the package, but on test mechanism).
----------------------------------------
2.3.0 2016-04-13
  - perlcritic tweaks, add documentation, better die messages. (GH#32,
    temp0)

  [ ENHANCEMENTS ]
    - 'git cpan import' now has options '--author_name' and
      '--author_email' to force author to those values. (GH#31)

  [ STATISTICS ]
    - code churn: 8 files changed, 78 insertions(+), 45 deletions(-)
   2016-04-10 09:52:55 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated to devel/p5-Git-CPAN-Patch-2.2.1
----------------------------------------
2.2.1 2016-02-06
  [ BUG FIXES ]
    - Test was failing if color.ui was set to always. (GH#29, reported by
      grinnz)

  [ STATISTICS ]
    - code churn: 3 files changed, 24 insertions(+), 13 deletions(-)
   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-09-05 17:31:58 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
(pkgsrc)
 - Add following line for make test
   BUILD_DEPENDS+=        p5-Devel-CheckOS-[0-9]*:../../devel/p5-Devel-CheckOS
   BUILD_DEPENDS+=        \ 
p5-Package-Constants-[0-9]*:../../devel/p5-Package-Constants
   BUILD_DEPENDS+=        \ 
p5-Parallel-ForkManager-[0-9]*:../../devel/p5-Parallel-ForkManager
   BUILD_DEPENDS+=        \ 
p5-Search-Elasticsearch-[0-9]*:../../devel/p5-Search-Elasticsearch
 - (Be careful, not all the dependent packages pass for 'make test', followings \ 
are suspect)
    p5-MooseX-App-Cmd-0.31
    git-base-2.5.1
    p5-SQL-Abstract-Limit-0.14.1nb6
    p5-IO-tty-1.12nb1

(upstream)
 - Update 2.0.4 to 2.2.0
---------------------
2.2.0 2015-08-09
  [ BUG FIXES ]
      - Allow git to prompt user when calling sendemail (GH#25, Arthur Axel
        fREW Schmidt)
      - Tags were printed with the warning "at line blah". (GH#22)

  [ ENHANCEMENTS ]
      - Improve error message. (GH#24, frioux)

  [ NEW FEATURES ]
      - Store module name in config instead of relying on commit messages
        (frioux, GH#26)

  [ STATISTICS ]
      - code churn: 8 files changed, 219 insertions(+), 438 deletions(-)

2.1.0 2015-06-01
  [ ENHANCEMENTS ]
      - Be a little more clever about finding out if the META repo is
        git-based.

  [ STATISTICS ]
      - code churn: 3 files changed, 22 insertions(+), 4 deletions(-)
   2015-07-12 20:56:37 by Thomas Klausner | Files touched by this commit (405)
Log message:
Comment out dependencies of the style
{perl>=5.16.6,p5-ExtUtils-ParseXS>=3.15}:../../devel/p5-ExtUtils-ParseXS
since pkgsrc enforces the newest perl version anyway, so they
should always pick perl, but sometimes (pkg_add) don't due to the
design of the {,} syntax.

No effective change for the above reason.

Ok joerg
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.