./devel/p5-Git-Repository, Perl interface to Git repositories

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.320nb1, Package name: p5-Git-Repository-1.320nb1, Maintainer: pkgsrc-users

Git::Repository is an interface to Git for the Perl programming language,
for scripted interactions with repositories. It's a low-level interface
that allows calling any Git command, whether porcelain or plumbing,
including bidirectional commands such as git commit-tree.

A Git::Repository object simply provides context to the git commands being
run. It is possible to call the command() and run() methods against the
class itself, and the context (typically current working directory) will
be obtained from the options and environment.


Required to run:
[lang/perl5] [devel/p5-System-Command] [devel/git-base] [devel/p5-Git-Version-Compare]

Required to build:
[devel/p5-namespace-autoclean] [pkgtools/cwrappers] [devel/p5-Test-Requires-Git]

Master sites: (Expand)

SHA1: c3d06b77dd16ac22568cf7f66851e882f8c6433b
RMD160: 6fd39abe4541883f61a266a54700db49912b7c7d
Filesize: 53.169 KB

Version history: (Expand)


CVS history: (Expand)


   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-06-18 22:27:08 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-Git-Repository to 1.320
----------------------------------------
1.320 2016-06-12 BOOK
    [ENHANCEMENTS]
    - Rewrite Git::Repository::Command's final_output() using
      System::Command's loop_on()
    [TESTS]
    - Fix a test that failed with Git versions with "comments" (Samit \ 
Badle)
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2016-06-05 15:30:47 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
(pkgsrc)
 - BUILD_DEPENDS+= added for make test
     p5-namespace-autoclean-[0-9]*:../../devel/p5-namespace-autoclean
     p5-Test-Requires-Git-[0-9]*:../../devel/p5-Test-Requires-Git

(upstream)
 - Updated devel/p5-Git-Repository to 1.319
----------------------------------------
1.319 2016-05-18 BOOK
    [DEPRECATION]
    - The has_git() test function from Test::Git is now obsoleted by
      Test::Requires::Git. It will issue a warning for now, and will be
      removed in a future version.
    [DOCUMENTATION]
    - Added tutorial entry "Initialize a test repository with a bundle"
    - Updated the "Sort git versions" tutorial entry with \ 
Git::Version::Compare
    [TESTS]
    - Use Test::Requires::Git instead of has_git to check if git is available
    - Fix a number of failing tests related to an incorrect plan (oops)
      or local git commit hooks.
   2016-03-13 14:03:14 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 1.318
Update DEPENDS

Upstream changes:
1.318 2016-03-12 BOOK
    [ENHANCEMENTS]
    - Extend version support to all existing version
    - Let Git::Version::Compare handle all version comparison code
    - eg/build-git can now build all Git versions since 1.0.0
    [DOCUMENTATION]
    - Minor documentation updates
    - URL corrections by DOLMEN

1.317 2016-02-13 BOOK
    [ENHANCEMENTS]
    - improved git binary detection in Git::Repository::Command
    - fixed version comparisons for 1.0.0a and 1.0.0b under Perl 5.6
    - test_repository( clone => ... ) now dies with a useful message
      when trying to call it with a broken Git
    - Git::Repository::Util provides utility functions for Git stuff
    - eg/build-git: a utility to build and install any Git version
    [DOCUMENTATION]
    - Tutorial entry: "Ignore the system and global configuration files"
    - spelling fix (RT #110027 by Gregor Herrmann)
    [TEST]
    - fix RT #89086 (reported by Alex Raguero)
    - new test: t/test-all-git.t to run the test suite against a directory
      full of git builds (if available)
    - tested against 513 versions of git (including all RC),
      from 1.0.0 to 2.7.1

1.316 2015-12-02 BOOK
    [ENHANCEMENTS]
    - avoid a warning if the filehandles have already been closed
      (related to System::Command 1.114 'interactive' option)
    [DOCUMENTATION]
    - add examples for `git log` and using callbacks with `$r->run`
      in Git::Repository::Tutorial
    [TESTS]
    - git-2.5.2 test suite compatibility fix (Petr ´┐Żabata)
   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-09-01 14:21:08 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Update 1.313 to 1.315
---------------------
1.315 Wed Jul 29 2015
    [ENHANCEMENTS]
    - Show exit status in 'unknown git error' message (TIMB)

1.314 Sat May 23 2015
    [ENHANCEMENTS]
    - simplified the internals of version comparisons
    - give the correct result for comparisons involving 1.0.0a and 1.0.0b
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.