./devel/p5-Module-Install-RTx, Perl5 module for building and installing RT extensions

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.39nb1, Package name: p5-Module-Install-RTx-0.39nb1, Maintainer: pkgsrc-users

This Perl 5 module is a helper module for RT extension writers to
install files into an existing RT installation.


Required to run:
[lang/perl5] [devel/p5-Module-Install]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

SHA1: 24ff1a93dd92efc6f82933a6e1fc59ef5e1b220f
RMD160: 4db6940b6db9e3735821ef24d1f1a8178c1c336c
Filesize: 26.702 KB

Version history: (Expand)


CVS history: (Expand)


   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2017-03-20 22:23:49 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-Module-Install-RTx to 0.39
-------------------------------------------
0.39 2017-02-20
- Support `remove_files => 1` parameter to force unlinking of files
  provided by previous versions
   2016-07-28 08:38:14 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.38

Upstream changes:
0.38 2016-07-14
 - Support `INSTALLDIRS=vendor`
 - Properly honor `$DESTDIR` at `make install` time
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2015-02-09 23:20:44 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Update to 0.37:

0.37 2014-12-24
 - Add the Module::Install::ReadmeFromPod dependency

0.36 2014-09-02
 - Add deprecated_rt and no_readme_generation flags to RTx()
 - Alter the right structures when requires_rt_plugin is called twice

0.35 2014-07-28
 - No changes since 0.34_05

0.34_05 2014-07-14
 - Apply consistent transformations to RTHOME as we do when prompting
 - Check Debian request-tracker4 install location by default as well

0.34_04 2014-06-26
 - Automatically generate a README

0.34_03 2014-06-19
 - Stop runtime code from clearing out inc/ if run as an author

0.34_02 2014-06-19
 - Fix requires_rt_plugin
 - Standardize error messages for rt_too_new and requires_rt

0.34_01 2014-06-19
 - Remove RT 3.8-specific code
 - Update documentation to reflect 3.8-era Plugin world order
 - Add requires_rt_plugin helper
 - Remove WITH_SUBDIRS support
 - Remove non-working PREFIX support
 - Add RT version information to META.yml
 - Default minimum perl version based on minimum RT version
 - Tidy Changes file

0.34 2014-05-20
 - Backcompat workaround so you can ship static/css and static/js and on
   4.0 we copy to html/NoAuth/{css,js}.  Isn't a full win for images which
   needed a dhandler hack under 4.0.

0.33 2014-03-17
 - Better error message when requires_rt dies
 - Release a pent up set of changes now that they've been tested

0.32_02 2014-02-10
 - Avoid some false positives that would offer a make upgrade-database
   which cannot work.

0.32_01 2014-01-10
 - Now that we aren't packaging extensions against 3.6, we can use
   cmp_versions imported from RT core rather than copy/paste.
 - new rt_too_new which allows you to bail out before being installed on a
   version of RT which is too new for you to function normally on
   (corollary to requires_rt).
 - requires_rt now dies if your RT is too old rather than just warning.

0.32 2013-09-06
 - new make upgrade-database command; this feature needs RT 4.2 or
   4.0.14+ for maximum benefit, and is used in the RTIR 3.0 release
   series

0.31 2013-04-08
 - Use the DatabaseAdmin configuration if supplied
 - Install /static/ on future 4.2 versions of RT

0.30 2012-11-06
 - remove a lot of old unused code
 - add support for a 4.1 feature that records database changes made by the
   extension
   2014-10-09 15:45:06 by Thomas Klausner | Files touched by this commit (456)
Log message:
Remove SVR4_PKGNAME, per discussion on tech-pkg.