./devel/p5-MooseX-LazyRequire, Required attributes which fail only when trying to use them

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.11nb2, Package name: p5-MooseX-LazyRequire-0.11nb2, Maintainer: pkgsrc-users

This module adds a lazy_required option to Moose attribute declarations.

The reader methods for all attributes with that option will throw an
exception unless a value for the attributes was provided earlier by a
constructor parameter or through a writer method.


Required to run:
[lang/perl5] [devel/p5-Moose] [devel/p5-aliased] [devel/p5-namespace-autoclean]

Required to build:
[devel/p5-Package-DeprecationManager] [devel/p5-Test-Fatal] [devel/p5-Test-CheckDeps]

Master sites: (Expand)

SHA1: 95f267699a6945b631466265c65be4dfaf34665d
RMD160: 301b18e2b388077172f7cce4fe4d8aa31ad3b732
Filesize: 25.785 KB

Version history: (Expand)


CVS history: (Expand)


   2016-06-09 14:10:09 by Makoto Fujiwara | Files touched by this commit (15)
Log message:
Add +BUILD_DEPENDS+= p5-Package-DeprecationManager-[0-9]* for make test
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-07-12 20:56:37 by Thomas Klausner | Files touched by this commit (405)
Log message:
Comment out dependencies of the style
{perl>=5.16.6,p5-ExtUtils-ParseXS>=3.15}:../../devel/p5-ExtUtils-ParseXS
since pkgsrc enforces the newest perl version anyway, so they
should always pick perl, but sometimes (pkg_add) don't due to the
design of the {,} syntax.

No effective change for the above reason.

Ok joerg
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2014-11-03 07:49:52 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.11

Upstream changes:
0.11      2014-08-16 20:49:14Z
  - lots of cleanup of metadata
  - canonical git repository is now https://github.com/moose/MooseX-LazyRequire
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.
   2013-07-27 10:39:10 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.10
Update DEPENDS

Upstream changes:
0.10      2013-03-15 13:09:48 PDT-0700  (Karen Etheridge)
  * use quotes around attribute name in error messages (David Precious)

0.09      2012-12-01 14:16:14 PST-0800  (Karen Etheridge)
  * Invalid tests that failed on perl 5.17.6 have been fixed (they were always
    invalid, but the changes to hash key ordering only now made the tests
    start failing in an obvious way) (RT#81419)
  * unnecessary dependency on MooseX::Types removed