./devel/p5-NEXT, Provide a pseudo-class NEXT (et al) that allows method redispatch

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.67nb1, Package name: p5-NEXT-0.67nb1, Maintainer: pkgsrc-users

NEXT.pm adds a pseudoclass named NEXT to any program that uses it. If a method
m calls $self-NEXT::m()>, the call to m is redispatched as if the calling
method had not originally been found.


Required to run:
[lang/perl5]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

SHA1: 97944f0ca8d59d65859436c661db1e4212ac6340
RMD160: cbb0d855999f9341a2f5795f874e7be73bee219d
Filesize: 11.247 KB

Version history: (Expand)


CVS history: (Expand)


   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-08-06 00:44:32 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-NEXT to 0.67
-----------------------------
0.67 2016-07-30 NEILB
    - Changed class names in SYNOPSIS from A, B, C, D to P, Q, R, S.
      This is avoid potential clash with core B:: namespace. RT#9734
      I didn't change the later examples in the doc, as I think they're ok.
    - Added mentions of next::method in the core "mro" module.
    - Changed all mentions of "NEXT.pm" in the doc to C<NEXT>.

0.66 2016-07-28 NEILB
    - split the "package EVERY" statement across two lines to hide it
      from PAUSE and help with resolving a permissions conflict with \ 
"Every".
    - Added prereqs, license type, and min perl version to dist metadata
    - Added github repo to dist metadata
    - Fixed pod error reported in RT#49984 and RT#100587,
      and rogue trailing spaces in pod, RT#64923

0.65_01 2016-07-20 NEILB
    - split the "package EVERY" statement across two lines to hide it
      from PAUSE and help with resolving a permissions conflict with \ 
"Every".
    - Added prereqs, license type, and min perl version to dist metadata
    - Added github repo to dist metadata
    - Fixed pod error reported in RT#49984 and RT#100587,
      and rogue trailing spaces in pod, RT#64923
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.
   2013-05-31 14:42:58 by Thomas Klausner | Files touched by this commit (2880)
Log message:
Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.
   2012-10-31 12:19:55 by Aleksej Saushev | Files touched by this commit (1460)
Log message:
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.