./devel/p5-Perl-MinimumVersion, Find a minimum required version of perl for Perl code

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.38nb3, Package name: p5-Perl-MinimumVersion-1.38nb3, Maintainer: pkgsrc-users

Perl::MinimumVersion takes Perl source code and calculates the minimum
version of perl required to be able to run it. Because it is based on
PPI, it can do this without having to actually load the code.

Currently it tests both the syntax of your code, and the use of explicit
version dependencies such as require 5.005.


Required to run:
[lang/perl5] [devel/p5-File-Find-Rule] [devel/p5-Params-Util] [devel/p5-PPIx-Regexp]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

SHA1: dda8f17a35a73622bb57fd2bef393bdd0c74e7c5
RMD160: 402f34d854b9e901ff154cfbb1a9a4cbaf1d0d66
Filesize: 29.911 KB

Version history: (Expand)


CVS history: (Expand)


   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-07-12 20:56:37 by Thomas Klausner | Files touched by this commit (405)
Log message:
Comment out dependencies of the style
{perl>=5.16.6,p5-ExtUtils-ParseXS>=3.15}:../../devel/p5-ExtUtils-ParseXS
since pkgsrc enforces the newest perl version anyway, so they
should always pick perl, but sometimes (pkg_add) don't due to the
design of the {,} syntax.

No effective change for the above reason.

Ok joerg
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2015-02-06 10:56:59 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 1.38
Update DEPENDS

Upstream changes:
1.38 2014-08-22
    - The doc for Perl::MinimumVersion now mentions perlver in both
      the DESCRIPTION and SEE ALSO sections. RT#98262 from pagenyon++.
    - Added mention of Perl::MinimumVersion::Fast to SEE ALSO.

1.37 2014-05-11
    - Removed the check for "stacked labels" that I added in 1.36, as \ 
it appears
      that I misinterpreted what the 5.14 change was, and broke at least one dist.
      Commented out the check in MinimumVersion.pm, and the specific subtests.
      Apologies to HMBRAND and all others affected
    - The way I was comparing versions in one of the new tests in 1.36 wasn't \ 
portable
      across old versions of Perl. Thanks to Paul Howarth for RT#95528.

1.36 2014-05-09
    - CHECK block requires 5.6.2
    - UNITCHECK block requires 5.10.0
    - Stacked labels on the same statement requires 5.14.0

1.35 2014-05-02
    - 'state' requires perl 5.10.0, even if you don't also see
      "use feature 'state'", because you can also write "use \ 
5.010" to
      enable 'state'. RT#67626
    - Dropped the rule that said "use base 'Exporter'" should make a
      dependency on Perl 5.008+ RT#89173
    - Improved the fix for RT#95023. Thanks again to Paul Howarth.

1.34 2014-04-24
    - The perlver script wasn't getting installed, because it's in
      a script/ directory. RT#95023, fix from ETHER.
    - t/02_main.t was failing on older versions of perl, because
      a min version is getting reported as '5.01301' on Perl 5.010 and later,
      but as '5.013010' on earlier Perls. RT#95023. I need to understand this
      better, but want to get a passing release out.

1.33 2014-04-24
    - Internals::SvREADONLY requires perl 5.8.0
    - handle features upto lexical_subs, which requires 5.18.0
      state, switch, unicode_strings, unicode_eval, evalbytes,
      current_sub, array_base, fc, lexical_subs
    - deprecate.pm requires perl 5.12 (Alexandr Ciornii)
    - require new version of PPIx::Regexp
    - detect while(readdir $dh) (Alexandr Ciornii)
    - Switched to Dist::Zilla
    - Added required versions of modules when use'ing them
    - Reformatted Changes as per CPAN::Changes::Spec
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.
   2013-10-31 04:22:47 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 1.32
Update DEPENDS

Upstream changes:
1.32 Tue 16 Jan 2013
    - require new version of PPIx::Regexp
    - skip sub named keys/each/values in _each_argument() (Pedro Melo, RT#82718)
    - detect open with reference to scalar (Alexandr Ciornii)

1.31 Tue  4 Dec 2012
    - sort $subref requires perl 5.6 (Alexandr Ciornii)

1.30 Wed 28 Nov 2012
    - 'each % { $foo }' incorrectly required perl 5.14 (RT#81505)
    - 02_main.t fails in rare cases (RT#81487)

1.29 Tue 27 Nov 2012
	- "Use of uninitialized value in null operation" fix.
	- Adding test for "utf8::is_utf" 5.8.1 special case
	- Recognize all versions in "use feature" bundle (Alexandr Ciornii)
	- Support regexes (Alexandr Ciornii)
	- detect changes in each/keys/values in 5.12 and 5.14 (Yasutaka ATARASHI, \ 
Alexandr Ciornii)
	- 2-arg binmode (Alexandr Ciornii)
	- postfix when (Alexandr Ciornii)
	- exists(&sub) (Kevin Ryde, Alexandr Ciornii)
	- _bugfix_magic_errno will return element (Alexandr Ciornii)
	- add 'encoding' to 5.8 pragmas (Alexandr Ciornii)
	- private methods _set_checks2skip and _set_collect_all_reasons for
	  Perl::Critic::Policy::Compatibility::PerlMinimumVersionAndWhy (Alexandr Ciornii)
	- temp file with open requires 5.8 (Alexandr Ciornii)