./devel/p5-Test-Requires-Git, Check your test requirements against the available version of Git

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.008nb1, Package name: p5-Test-Requires-Git-1.008nb1, Maintainer: pkgsrc-users

Test::Requires::Git checks if the version of Git available for testing
meets the given requirements.
The "current git" is obtained by running git --version (so the first git
binary found in the PATH will be tested).
If the checks fail, then all tests will be skipped.


Required to run:
[lang/perl5]

Required to build:
[pkgtools/cwrappers] [devel/p5-Git-Version-Compare]

Master sites:

SHA1: b2af47553dcaab3ae51053855b63fdf95844572c
RMD160: c4df8bac828f84209aaa10fcfa29d63ceb7b0c70
Filesize: 17.002 KB

Version history: (Expand)


CVS history: (Expand)


   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2017-03-20 14:59:01 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-Test-Requires-Git to 1.008
-------------------------------------------
1.008 2017-03-07 BOOK
    - Make sure the test suite works as expected when @INC does not contain '.'
      (closes RT #120537, thanks to KENTNL for the report)
   2016-10-10 15:00:00 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-Test-Requires-Git to 1.007
-------------------------------------------
1.007 2016-10-02 BOOK
    - Add an extra diagnostic reporting the git version used for testing
      (with a scheme to limit the number of times it's output, so as not
      to pollute test output too much)
   2016-08-11 02:08:22 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 1.006

Upstream changes:
1.006 2016-05-08 BOOK
    - Documentation improvements
    - Code improvements
    - Add tests for git versions with comments
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2016-04-16 15:42:24 by Makoto Fujiwara | Files touched by this commit (1)
Log message:
- Add following three lines.
  +# for make test
  +BUILD_DEPENDS+= p5-Git-Version-Compare-[0-9]*:../../devel/p5-Git-Version-Compare
  +BUILD_DEPENDS+= p5-namespace-clean-[0-9]*:../../devel/p5-namespace-clean
   2016-04-16 15:18:17 by Makoto Fujiwara | Files touched by this commit (3)
Log message:
Import p5-Test-Requires-Git-1.005 as devel/p5-Test-Requires-Git.

Test::Requires::Git checks if the version of Git available for testing
meets the given requirements.
The "current git" is obtained by running git --version (so the first git
binary found in the PATH will be tested).
If the checks fail, then all tests will be skipped.