./devel/pcre-ocaml, Perl compatible regular expressions for OCaml

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 7.3.4nb1, Package name: pcre-ocaml-7.3.4nb1, Maintainer: jaapb

This OCaml-library interfaces the PCRE (Perl-compatible regular
expressions) library which is written in C. it can be used for matching
regular expressions which are written in "Perl"-style.


Required to run:
[lang/ocaml] [devel/ocaml-findlib] [devel/pcre] [misc/ocaml-opam] [devel/ocaml-jbuilder] [devel/ocaml-base] [devel/ocaml-stdio] [devel/ocaml-configurator]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 4971469cc943a85c1a44254ad1b823d6ae6e9574
RMD160: fed14ea19988e50335bf892f1e6928f75c7ed677
Filesize: 43.61 KB

Version history: (Expand)


CVS history: (Expand)


   2018-01-10 17:21:20 by Jaap Boender | Files touched by this commit (5) | Package updated
Log message:
Updated package devel/pcre-ocaml to version 7.3.4.

Changes include a build system switch (to jbuilder and topkg), and
bugfixes and performance improvements.
   2017-09-08 11:51:27 by Jaap Boender | Files touched by this commit (113) | Package updated
Log message:
Recursive revbump associated with update of ocaml to 4.05
   2017-07-31 00:32:28 by Thomas Klausner | Files touched by this commit (229)
Log message:
Switch github HOMEPAGEs to https.
   2017-07-11 14:31:37 by Jaap Boender | Files touched by this commit (3) | Package updated
Log message:
Updated package to latest version 7.2.3. Changes include:

2016-02-25:  Minor version release v7.2.3:

               Fixed callout bug introduced with v7.2.0.

             Thanks to Raman Varabets for the bug report!

2016-02-23:  Fixed linking problem with old versions of PCRE (< 8.20).

             Fixed backward compatibility issue with OCaml <= 3.12.

2016-02-22:  Fixed a subgroup matching bug.

Thanks to Cheng Lou for the bug report!
   2016-12-30 12:17:03 by Jaap Boender | Files touched by this commit (89) | Package updated
Log message:
Recursive revbump associated with ocaml update to 4.04.
   2016-06-25 16:30:31 by Jaap Boender | Files touched by this commit (2) | Package updated
Log message:
Updated package to work with ocaml.mk. No upstream changes.
   2016-06-20 21:39:43 by Jaap Boender | Files touched by this commit (1)
Log message:
Revbump to make sure package gets compiled with newer mk/ocaml.mk.
   2016-05-05 17:53:08 by Jaap Boender | Files touched by this commit (1) | Package updated
Log message:
Updated package to use correct findlib directory