./devel/py-flake8-import-order, Flake8 and pylama plugin that checks the ordering of import statements

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.15, Package name: py27-flake8-import-order-0.15, Maintainer: pkgsrc-users

A flake8 and Pylama plugin that checks the ordering of your imports.

In general stdlib comes first, then 3rd party, then local packages,
and that each group is individually alphabetized.

It will not check anything else about the imports. Merely that they
are grouped and ordered correctly.


Required to run:
[devel/py-codestyle]

Required to build:
[devel/py-test] [devel/py-flake8] [devel/py-lama]

Master sites:

SHA1: fea4545a365f4072d944ddb2ee2644ed165a156b
RMD160: 7308d5b644a1aa73ce6cf134312b496f7c4d473f
Filesize: 16.301 KB

Version history: (Expand)


CVS history: (Expand)


   2017-11-08 09:11:36 by Adam Ciarcinski | Files touched by this commit (2) | Package updated
Log message:
py-flake8-import-order: updated to 0.15

0.15:
Drop Python 3.3 support, as Python 3.3 is beyond it's end of lfe.
Correct the flake8 entrypoint to report all I errors, this may result in I2XX \ 
errors being reported that were absent previously.
Support in-line # noqa comments specifing only the error codes to be ignored, \ 
e.g., # noqa: I101.
Accept only # noqa directives on the line reporting the error, see limitations.
   2017-11-02 08:13:24 by Adam Ciarcinski | Files touched by this commit (2) | Package updated
Log message:
py-flake8-import-order: updated to 0.14.3

0.14.3:
* Bug fix, allow for noqa directives to work with I202.
   2017-10-31 14:00:55 by Adam Ciarcinski | Files touched by this commit (2) | Package updated
Log message:
py-flake8-import-order: updated to 0.14.2

0.14.2:
Bug fix, ensure the plugin is invoked by flake8.
   2017-10-28 09:42:10 by Adam Ciarcinski | Files touched by this commit (2) | Package updated
Log message:
py-flake8-import-order: updated to 0.14.1

0.14.1:
* Bug fix, cope with multi-line imports when considering I202.
   2017-10-25 11:11:59 by Adam Ciarcinski | Files touched by this commit (2) | Package updated
Log message:
py-flake8-import-order: updated to 0.14

0.14:
* Fixed I201 error raising for cryptography style.
* Added I202 error when there is an additional newline in a section of
  imports.
* Added ``ntpath`` and ``os2emxpath`` to stdlib list.
   2017-08-14 21:27:27 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Updated py-flake8-import-order to 0.13.

0.13 2017-07-29
---------------

* Added ``secrets`` to stdlib list.
* Allow for any style to use application-package grouping.
   2017-04-04 16:41:03 by Thomas Klausner | Files touched by this commit (4)
Log message:
Import py-flake8-import-order-0.12 as devel/py-flake8-import-order.

A flake8 and Pylama plugin that checks the ordering of your imports.

In general stdlib comes first, then 3rd party, then local packages,
and that each group is individually alphabetized.

It will not check anything else about the imports. Merely that they
are grouped and ordered correctly.