./devel/python-mode, Emacs mode for editing python files

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.0nb2, Package name: python-mode-1.0nb2, Maintainer: pkgsrc-users

An Emacs editing mode for Python scripts.


Required to run:
[editors/emacs24]

Master sites:

SHA1: 974a7714000238bd0423c5598d781c9987929b83
RMD160: 6f2abe80b7eae9123da10a3c0f447f7792caedb6
Filesize: 53.022 KB

Version history: (Expand)


CVS history: (Expand)


   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2013-06-10 23:51:04 by John Nemeth | Files touched by this commit (2)
Log message:
builds with emacs24
   2013-02-17 20:18:11 by David A. Holland | Files touched by this commit (90)
Log message:
Revbump all elisp packages after emacs changes.
   2012-10-31 12:19:55 by Aleksej Saushev | Files touched by this commit (1460)
Log message:
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
   2011-10-09 04:49:48 by Kimmo Suominen | Files touched by this commit (1)
Log message:
This can be built with emacs23nox too.
   2009-08-06 03:44:57 by Min Sik Kim | Files touched by this commit (67)
Log message:
PKGREVISION bump for elisp packages because of bytecode format changes
in emacs23.
   2009-08-05 08:47:53 by Min Sik Kim | Files touched by this commit (1)
Log message:
devel/python-mode can be built with emacs23.
   2008-10-11 11:31:58 by Masao Uebayashi | Files touched by this commit (100)
Log message:
Move mk/emacs.mk to editors/emacs/modules.mk.

Don't call pkg_info to get the installed Emacs version; always use the
version matching EMACS_TYPE set by users.  Be DEPENDS to it.  This should
address pkg/37146 by Aleksey Cheusov.

While here convert some emacs lisp packages to user-destdir.