./devel/ruby-deprecated, Aid developers working with deprecated code

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.0.1nb1, Package name: ruby23-deprecated-2.0.1nb1, Maintainer: taca

This is a small library intended to aid developers working with
deprecated code. The idea comes from the 'D' programming language,
where developers can mark certain code as deprecated, and then
allow/disallow the ability to execute deprecated code.


Required to run:
[lang/ruby23-base]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 366fe846dbe85b7abc45e70e3439afdfd2bbe6dd
RMD160: a5dcfec594a891368b3db6c2f4c09d0513720298
Filesize: 6 KB

Version history: (Expand)


CVS history: (Expand)


   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-09-25 08:06:36 by Takahiro Kambe | Files touched by this commit (1) | Package updated
Log message:
Update HOMEPAGE.
Avoid using rubyforge.org since it stopped most of services.
   2011-08-12 17:56:38 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Avoid to define constant Deprecate since it is conflict with rubygems.
Newer rubygems poorly defines module Deprecate which could be
Gem::Deprecate.

Bump PKGREVISION.
   2010-09-10 07:32:01 by Takahiro Kambe | Files touched by this commit (1)
Log message:
* Use lang/ruby/gem.mk instead of misc/rubygems/rubygem.mk.
* Remove default value of GEM_BUILD.

Also add caution for updating version.
   2009-10-20 04:50:45 by Takahiro Kambe | Files touched by this commit (4) | Imported package
Log message:
Importing devel/ruby-deprecated version 2.0.1.

This is a small library intended to aid developers working with
deprecated code.  The idea comes from the 'D' programming language,
where developers can mark certain code as deprecated, and then
allow/disallow the ability to execute deprecated code.