./devel/ruby-memoist, Replacement of memoizable, memoize methods invocation

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.16.0, Package name: ruby23-memoist-0.16.0, Maintainer: tsutsui

Memoist a ruby library that provides memoize methods,
which is an extraction of ActiveSupport::Memoizable.


Master sites:

SHA1: daa70c5adf7777010fa29a80ed798334780cb31f
RMD160: 764a9f6e9edd10080a28f5346bdf0bb95990b31a
Filesize: 12 KB

Version history: (Expand)


CVS history: (Expand)


   2017-07-08 05:11:05 by Izumi Tsutsui | Files touched by this commit (2) | Package updated
Log message:
Update ruby-memoist to 0.16.0.

No upstream changelog (except github log),
but there is an implicit API change that breaks pkgsrc/net/mikutter.
mikutter will be updated to the latest version which support newer memoist.
   2016-11-01 17:50:31 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-memoist to 0.15.0.

* Add the frozen string literal pragma for ruby 2.3.0.
* Add a benchmark for basic performance of memoised methods
* Add a hit counter... 90s style
* Use SVG badge over PNG
* Ensure we don't load uninitialized variables in the test
* Avoid overwriting the memoized_methods helper
   2016-01-09 19:38:26 by Izumi Tsutsui | Files touched by this commit (4)
Log message:
Import ruby-memoist-0.14.0 as devel/ruby-memoist.

Memoist a ruby library that provides memoize methods,
which is an extraction of ActiveSupport::Memoizable.