./devel/ruby-rb-kqueue, Ruby wrapper for BSDs kqueue, using FFI

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.2.5, Package name: ruby23-rb-kqueue-0.2.5, Maintainer: pkgsrc-users

This is a simple wrapper over the kqueue (supported on FreeBSD, NetBSD,
OpenBSD, and Darwin). It uses the FFI gem to avoid having to compile a C
extension.

API documentation is available on rdoc.info:
http://rdoc.info/projects/mat813/rb-kqueue.


Required to run:
[devel/ruby-ffi]

Master sites:

SHA1: 7038671d979987af69b3d5d42df3e53d7a2261ae
RMD160: c760de0d94685ff4482effd77c2e4030dd0f9924
Filesize: 18.5 KB

Version history: (Expand)


CVS history: (Expand)


   2017-06-04 18:11:29 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-rb-kqueue to 0.2.5.

0.2.5 (2017/05/16)

* Use types in agreement with the event.h of native operating systems.
* Use EVFILT_ flags in agreement with the event.h of native operating systems.
* Add RSpec development dependency.
* Generate initial RSpec config.
* [WIP] Write basic tests for KQueue::Queue#watch_file.
   2017-01-09 16:52:34 by Takahiro Kambe | Files touched by this commit (4)
Log message:
Add ruby-rb-kqueue 0.2.4.

This is a simple wrapper over the kqueue (supported on FreeBSD, NetBSD,
OpenBSD, and Darwin).  It uses the FFI gem to avoid having to compile a C
extension.

API documentation is available on rdoc.info:
http://rdoc.info/projects/mat813/rb-kqueue.