./devel/ruby-readline, Ruby extension to readline library

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.4.5, Package name: ruby24-readline-2.4.5, Maintainer: taca

This is a Ruby extension to the readline library, which is actually a
part of the Ruby distribution.


Required to run:
[devel/readline] [lang/ruby24-base]

Required to build:
[pkgtools/cwrappers]

Package options: readline, ruby-build-ri-db

Master sites: (Expand)

SHA1: b5be590b37487248da3a85541a62fb81f7f7e29a
RMD160: b0704071c12223b416ca5bd52a52671376d8ad5c
Filesize: 9828.82 KB

Version history: (Expand)


CVS history: (Expand)


   2019-02-03 23:20:35 by Takahiro Kambe | Files touched by this commit (3)
Log message:
Add missing Ruby 2.6 support.
   2019-01-13 03:36:28 by Takahiro Kambe | Files touched by this commit (3)
Log message:
lang/ruby22: explicitly specify RUBY_VERSIONS_ACCEPTED

Explicitly specify RUBY_VERSIONS_ACCEPTED to all versions.
   2017-09-15 02:37:14 by Takahiro Kambe | Files touched by this commit (2)
Log message:
Reset PKGREVISION.
   2017-05-30 17:46:22 by Takahiro Kambe | Files touched by this commit (10)
Log message:
Replace RUBY_VERSION_FULL with RUBY_VERSION since there is no
RUBY_VERSION_FULL contains Ruby's patchlevel.
   2017-05-30 16:19:51 by Takahiro Kambe | Files touched by this commit (2)
Log message:
* Remove code for ruby18.
* Drop setting RUBY_VERSIONS_ACCEPTED since it is now default value.
   2017-04-22 20:27:05 by Takahiro Kambe | Files touched by this commit (11)
Log message:
Remove 18 from RUBY_VERSIONS_ACCEPTED.
   2016-09-08 17:19:19 by Joerg Sonnenberger | Files touched by this commit (42)
Log message:
Rename RUBY_VERSION_SUPPORTED into _RUBY_VERSIONS_ACCEPTED to follow the
naming scheme of the other multi-version packages. Add support for the
coorresponding RUBY_VERSIONS_INCOMPATIBLE list.
   2016-03-14 01:59:07 by Tobias Nygren | Files touched by this commit (16)
Log message:
remove references to ruby200