./devel/ruby-rspec, Behaviour Driven Development framework for Ruby

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 3.9.0, Package name: ruby24-rspec-3.9.0, Maintainer: pkgsrc-users

Behaviour Driven Development for Ruby

# RSpec Core

rspec-2.x is a meta-gem, which depends on the rspec-core, rspec-expectations
and rspec-mocks gems. Each of these can be installed separately and actived in
isolation with the `gem` command. Among other benefits, this allows you to use
rspec-expectations, for example, in Test::Unit::TestCase if you happen to
prefer that style.

Conversely, if you like RSpec's approach to declaring example groups and
examples (`describe` and `it`) but prefer Test::Unit assertions and mocha, rr
or flexmock for mocking, you'll be able to do that without having to load the
components of rspec that you're not using.

## Documentation

* [Cucumber features](http://relishapp.com/rspec/rspec-core)
* [RDoc](http://rubydoc.info/gems/rspec-core/2.4.0/frames)


Required to run:
[devel/ruby-rspec-core] [devel/ruby-rspec-mocks] [devel/ruby-rspec-expectations] [lang/ruby24-base]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 887d4650185264cf1b86516e9dc71e7513bdc83a
RMD160: ae15590c7a72b0df00351a7231e381067c895cec
Filesize: 10.5 KB

Version history: (Expand)


CVS history: (Expand)


   2019-11-02 15:40:25 by Takahiro Kambe | Files touched by this commit (1)
Log message:
devel/ruby-rspec: Add USE_LANGUAGES

Add "USE_LANGUAGES=	# none".
   2019-11-02 15:37:09 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
devel/ruby-rspec: update to 3.9.0

Update ruby-rspec to 3.9.0.

This is meta rubygems and no changes here.
   2019-02-06 16:15:31 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
devel/ruby-rspec: update to 3.8.0

Update dependency; This package is meta gem for
ruby-rspec-{core,expectations,mocks}.
   2018-03-14 15:22:15 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
devel/ruby-rspec: update to 3.7.0

This package is meta gem for ruby-rspec-{core,expectations,mocks}.
   2017-09-04 20:08:31 by Thomas Klausner | Files touched by this commit (163)
Log message:
Follow some redirects.
   2017-06-05 16:07:47 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
Update ruby-rspec to 3.6.0.

This is a kind of meta package, contains ruby-rspec-core,
ruby-rspec-expectations and ruby-rspec-mocks.
   2016-10-09 17:05:57 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
Update ruby-rspec to 3.5.0.

This is meta-gem for rspsc-core, rpsec-expectations and rspec-mocks.
   2015-11-29 15:53:59 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-rspec to 3.4.0.

This is a meta ruby gem package for rspec-core, rspec-expectations
and rspec-mocks.