./devel/ruby-rugged, Ruby bindings to libgit2

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.27.5, Package name: ruby24-rugged-0.27.5, Maintainer: pkgsrc-users

Rugged is a library for accessing libgit2 in Ruby. It gives you the speed
and portability of libgit2 with the beauty of the Ruby language.


Required to run:
[devel/libgit2] [lang/ruby24-base]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 7b6c75f446aab434f236d3c4e1b808f2e69100d9
RMD160: c807c5cad4d1b8097f4080e2be0cb624cd9afa31
Filesize: 1130 KB

Version history: (Expand)


CVS history: (Expand)


   2018-10-18 16:44:26 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
devel/ruby-rugged: update to 0.27.5

Catch up to libgit2 0.27.5.
   2018-09-23 17:13:53 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
devel/ruby-rugged: update to 0.27.4

Catch up to devel/libgit2.
   2018-06-06 06:46:05 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
devel/ruby-rugged: update to 0.27.1

Basically, catch up to libgit2 0.27.1.  For more detail, please refer:

<https://github.com/libgit2/rugged/compare/v0.26.0...v0.27.1>
   2017-07-31 16:25:46 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-rugged to 0.26.0.

* Allow disabling rename detection for merge operations.
* Documentation fix: Iterator -> Enumerator
* Use Gem.win_platform? instead of custom code
* add a little hint in the readme for google
* cmake: honor CMAKE_FLAGS environment variable
* cmake: honor `--with-sha1dc`
* Better error messages for bad signature hash keys
* Catch up to libgit2 0.26.
* Add a method to parse a signature from a buffer
   2017-02-18 14:18:17 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-rugged to 0.25.1.1.

* Catch up to libgit2 0.25.0.
* Add support for Ruby 2.4.0.
* Some documentation improvements.
   2017-02-15 01:55:08 by Joerg Sonnenberger | Files touched by this commit (1)
Log message:
Needs openssl.
   2016-03-08 16:35:59 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-rugged to 0.24.0.

This updates the bundled libgit2 to version 0.24.0.
   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.