./editors/emacs21-nox11, GNU editing macros (editor)

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 21.4anb13, Package name: emacs21-nox11-21.4anb13, Maintainer: pkgsrc-users

GNU Emacs is a self-documenting, customizable, extensible real-time
display editor.

Users new to Emacs will be able to use basic features fairly rapidly
by studying the tutorial and using the self-documentation features.
Emacs also has an extensive interactive manual browser. It is easily
extensible since its editing commands are written in Lisp.

GNU Emacs's many special packages handle mail reading (RMail) and
sending (Mail), outline editing (Outline), compiling (Compile),
running subshells within Emacs windows (Shell), running a Lisp
read-eval-print loop (Lisp-Interaction-Mode), automated psychotherapy
(Doctor :-) and many more.

This package contains Emacs version 21, built without X11 support.


Required to run:
[lang/perl5]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

SHA1: cdb33731180fe4a912838af805dd35e3f55394d4
RMD160: c312e739935b56d08783bbfe97992297a363cb8a
Filesize: 19925.276 KB

Version history: (Expand)


CVS history: (Expand)


   2016-12-30 23:18:56 by Thomas Klausner | Files touched by this commit (1)
Log message:
Fix options framework abuse by emacs21-nox11.
   2013-02-17 08:48:03 by David A. Holland | Files touched by this commit (7)
Log message:
Put the Emacs version in all the DESCR files. Ride the bumps I just did.
   2013-02-17 01:22:37 by David A. Holland | Files touched by this commit (2)
Log message:
Change PKGNAME from emacs-nox11-21.4a to emacs21-nox11-21.4a.
   2012-10-03 13:43:48 by Aleksej Saushev | Files touched by this commit (150)
Log message:
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
   2011-03-21 07:05:45 by OBATA Akio | Files touched by this commit (3)
Log message:
Add user-destdir installation support.
   2011-02-08 14:20:14 by Hiramatsu Yoshifumi | Files touched by this commit (7)
Log message:
Instead of extracting version string from PKGNAME, use
${_EMACS_VERSION_MAJOR} and ${_EMACS_VERSION_MINOR} to determine installed
version of emacs.

Also, set minimum version of _EMACS_REQD to the same as
${_EMACS_VERSION_MAJOR}.${_EMACS_VERSION_MINOR}. Otherwise, buildlink
does not work for emacs lisp libraries.

Should fix PR/42763.
   2009-03-20 20:25:55 by Joerg Sonnenberger | Files touched by this commit (1252)
Log message:
Simply and speed up buildlink3.mk files and processing.
This changes the buildlink3.mk files to use an include guard for the
recursive include. The use of BUILDLINK_DEPTH, BUILDLINK_DEPENDS,
BUILDLINK_PACKAGES and BUILDLINK_ORDER is handled by a single new
variable BUILDLINK_TREE. Each buildlink3.mk file adds a pair of
enter/exit marker, which can be used to reconstruct the tree and
to determine first level includes. Avoiding := for large variables
(BUILDLINK_ORDER) speeds up parse time as += has linear complexity.
The include guard reduces system time by avoiding reading files over and
over again. For complex packages this reduces both %user and %sys time to
half of the former time.
   2008-10-11 11:31:58 by Masao Uebayashi | Files touched by this commit (100)
Log message:
Move mk/emacs.mk to editors/emacs/modules.mk.

Don't call pkg_info to get the installed Emacs version; always use the
version matching EMACS_TYPE set by users.  Be DEPENDS to it.  This should
address pkg/37146 by Aleksey Cheusov.

While here convert some emacs lisp packages to user-destdir.