./emulators/snes9x, Super Nintendo Entertainment System (SNES) emulator

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.43nb1, Package name: snes9x-1.43nb1, Maintainer: pkgsrc-users

Snes9x is a portable, freeware Super Nintendo Entertainment System (SNES)
emulator. It basically allows you to play most games designed for the SNES
and Super Famicom Nintendo game systems on your PC or Workstation; which
includes some real gems that were only ever released in Japan.


Required to run:
[devel/libusb-compat]

Required to build:
[pkgtools/x11-links] [pkgtools/cwrappers]

Master sites:

SHA1: c6883c451aeb442030862ec19a8dca25ee02d82c
RMD160: d2003f7afb208109405b41f4eec586b93518f9b2
Filesize: 992.433 KB

Version history: (Expand)


CVS history: (Expand)


   2018-02-28 00:56:10 by Pierre Pronchery | Files touched by this commit (25)
Log message:
Revbump for packages depending on devel/libusb{,compat}
   2018-02-10 14:53:49 by Pierre Pronchery | Files touched by this commit (39)
Log message:
Import global switch for libusb's implementation [2/2]

This switch is meant to be used by packages requiring an implementation of the
former libusb (as in devel/libusb). The original implementation can be
chosen by setting LIBUSB_TYPE to "native".

The alternative implementation libusb-compat (as in devel/libusb-compat) wraps
libusb1 (in devel/libusb1). This implementation can be chosen by setting
LIBUSB_TYPE to "compat". On NetBSD, it has the advantage of not \ 
requiring root
privileges to locate and use USB devices without a kernel driver.

This second part switches packages using libusb to this framework. It does not
change compilation options or dependencies at this point.

Compile-tested on most packages affected and available on NetBSD/amd64.
   2018-01-01 23:30:04 by Roland Illig | Files touched by this commit (537)
Log message:
Sort PLIST files.

Unsorted entries in PLIST files have generated a pkglint warning for at
least 12 years. Somewhat more recently, pkglint has learned to sort
PLIST files automatically. Since pkglint 5.4.23, the sorting is only
done in obvious, simple cases. These have been applied by running:

  pkglint -Cnone,PLIST -Wnone,plist-sort -r -F
   2017-01-19 19:52:30 by Alistair G. Crooks | Files touched by this commit (352)
Log message:
Convert all occurrences (353 by my count) of

	MASTER_SITES= 	site1 \
			site2

style continuation lines to be simple repeated

	MASTER_SITES+= site1
	MASTER_SITES+= site2

lines. As previewed on tech-pkg. With thanks to rillig for fixing pkglint
accordingly.
   2015-11-03 21:31:11 by Alistair G. Crooks | Files touched by this commit (211)
Log message:
Add SHA512 digests for distfiles for emulators category

Problems found with existing digests:
	Package suse131_libSDL
	1c4d17a53bece6243cb3e6dd11c36d50f851a4f4 [recorded]
	da39a3ee5e6b4b0d3255bfef95601890afd80709 [calculated]
	Package suse131_libdbus
	de99fcfa8e2c7ced28caf38c24d217d6037aaa56 [recorded]
	da39a3ee5e6b4b0d3255bfef95601890afd80709 [calculated]
	Package suse131_qt4
	94daff738912c96ed8878ce1a131cd49fb379206 [recorded]
	886206018431aee9f8a01e1fb7e46973e8dca9d9 [calculated]

Problems found locating distfiles for atari800, compat12, compat 13,
compat14, compat15, compat20, compat30, compat40, compat50,
compat50-x11, compat51, compat51-x11, compat60, compat61,
compat61-x11, fmsx, osf1_lib, vice, xbeeb, xm7.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-03-31 17:27:06 by Joerg Sonnenberger | Files touched by this commit (1)
Log message:
Help detecting X11 libraries.
   2015-01-01 11:03:58 by David A. Holland | Files touched by this commit (1)
Log message:
Use BROKEN_ON_PLATFORM with LP64PLATFORMS.
   2014-01-09 13:38:04 by Jonathan Perkin | Files touched by this commit (1)
Log message:
Needs libusb.