./emulators/suse131_gtk2, Linux compatibility package for GTK+-2.x

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 13.1nb8, Package name: suse_gtk2-13.1nb8, Maintainer: pkgsrc-users

Linux compatibility package based on the openSUSE Linux distribution.
Please visit http://www.opensuse.org/ for more information about openSUSE
Linux.

This package supports running ELF binaries linked with glibc2 that
require GTK+-2.x shared libraries.

DEINSTALL [+/-]

Required to run:
[emulators/suse131_freetype2] [emulators/suse131_glx] [emulators/suse131_fontconfig] [emulators/suse131_glib2]

Required to build:
[pkgtools/cwrappers]

Master sites:


Version history: (Expand)


CVS history: (Expand)


   2016-06-17 19:21:39 by Izumi Tsutsui | Files touched by this commit (26) | Package updated
Log message:
Update more RPMs from Suse 13.1.
   2015-11-03 21:31:11 by Alistair G. Crooks | Files touched by this commit (211)
Log message:
Add SHA512 digests for distfiles for emulators category

Problems found with existing digests:
	Package suse131_libSDL
	1c4d17a53bece6243cb3e6dd11c36d50f851a4f4 [recorded]
	da39a3ee5e6b4b0d3255bfef95601890afd80709 [calculated]
	Package suse131_libdbus
	de99fcfa8e2c7ced28caf38c24d217d6037aaa56 [recorded]
	da39a3ee5e6b4b0d3255bfef95601890afd80709 [calculated]
	Package suse131_qt4
	94daff738912c96ed8878ce1a131cd49fb379206 [recorded]
	886206018431aee9f8a01e1fb7e46973e8dca9d9 [calculated]

Problems found locating distfiles for atari800, compat12, compat 13,
compat14, compat15, compat20, compat30, compat40, compat50,
compat50-x11, compat51, compat51-x11, compat60, compat61,
compat61-x11, fmsx, osf1_lib, vice, xbeeb, xm7.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-07-28 10:49:16 by Thomas Klausner | Files touched by this commit (42) | Package updated
Log message:
Update RPMs from latest openSUSE 13.1 files.
From Rin Okuyama in PR 50082.
   2015-04-09 12:40:12 by Thomas Klausner | Files touched by this commit (4) | Package updated
Log message:
Add shared-mime-info rpm to gtk2 emulation package. This matches
what suse121_gtk2 does and fixes the first part of PR 48666, as
Nicolas Joly found out.

Run update-mime-database in INSTALL, and add an appropriate cleanup
rule to DEINSTALL.

Bump PKGREVISION.
   2015-02-16 11:15:50 by Jonathan Perkin | Files touched by this commit (92)
Log message:
Put back PKGNAME definitions.
   2015-02-11 10:38:19 by OBATA Akio | Files touched by this commit (92)
Log message:
Revert
 define PKGNAME instead of fake DISTNAME
PKGNAME is unstable variable in current pkgsrc framework, so packages must not
rely on it.
   2015-01-15 10:37:05 by OBATA Akio | Files touched by this commit (2) | Package updated
Log message:
   openSUSE Security Update: Security update for jasper
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2015:0042-1
Rating:             moderate
References:         #909474 #909475
Cross-References:   CVE-2014-8137
Affected Products:
                    openSUSE 13.1
______________________________________________________________________________

   An update that solves one vulnerability and has one errata
   is now available.

Description:

         The follow issues were fixed with this update:
         - CVE-2014-8137  double-free in jas_iccattrval_destroy()(bnc#909474)
         - CVE-2014-8138  heap overflow in jas_decode() (bnc#909475)

References:

   http://support.novell.com/security/cve/ … -8137.html
   https://bugzilla.suse.com/show_bug.cgi?id=909474
   https://bugzilla.suse.com/show_bug.cgi?id=909475
   2014-12-16 02:59:04 by OBATA Akio | Files touched by this commit (2) | Package updated
Log message:
Update jasper pkg in suse131_gtk2.
Bump PKGREVISION to 4.

   openSUSE Security Update: Security update for jasper
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2014:1644-1
Rating:             moderate
References:         #906364
Cross-References:   CVE-2014-9029
Affected Products:
                    openSUSE 13.2
                    openSUSE 13.1
                    openSUSE 12.3
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   jasper was updated to fix one security issue.

   This security issue was fixed:
   - Heap overflows in libjasper (CVE-2014-9029).