Subject: CVS commit: pkgsrc/devel/p5-Module-Install-RTx
From: Thomas Klausner
Date: 2015-02-09 23:20:44
Message id:

Log Message:
Update to 0.37:

0.37 2014-12-24
 - Add the Module::Install::ReadmeFromPod dependency

0.36 2014-09-02
 - Add deprecated_rt and no_readme_generation flags to RTx()
 - Alter the right structures when requires_rt_plugin is called twice

0.35 2014-07-28
 - No changes since 0.34_05

0.34_05 2014-07-14
 - Apply consistent transformations to RTHOME as we do when prompting
 - Check Debian request-tracker4 install location by default as well

0.34_04 2014-06-26
 - Automatically generate a README

0.34_03 2014-06-19
 - Stop runtime code from clearing out inc/ if run as an author

0.34_02 2014-06-19
 - Fix requires_rt_plugin
 - Standardize error messages for rt_too_new and requires_rt

0.34_01 2014-06-19
 - Remove RT 3.8-specific code
 - Update documentation to reflect 3.8-era Plugin world order
 - Add requires_rt_plugin helper
 - Remove WITH_SUBDIRS support
 - Remove non-working PREFIX support
 - Add RT version information to META.yml
 - Default minimum perl version based on minimum RT version
 - Tidy Changes file

0.34 2014-05-20
 - Backcompat workaround so you can ship static/css and static/js and on
   4.0 we copy to html/NoAuth/{css,js}.  Isn't a full win for images which
   needed a dhandler hack under 4.0.

0.33 2014-03-17
 - Better error message when requires_rt dies
 - Release a pent up set of changes now that they've been tested

0.32_02 2014-02-10
 - Avoid some false positives that would offer a make upgrade-database
   which cannot work.

0.32_01 2014-01-10
 - Now that we aren't packaging extensions against 3.6, we can use
   cmp_versions imported from RT core rather than copy/paste.
 - new rt_too_new which allows you to bail out before being installed on a
   version of RT which is too new for you to function normally on
   (corollary to requires_rt).
 - requires_rt now dies if your RT is too old rather than just warning.

0.32 2013-09-06
 - new make upgrade-database command; this feature needs RT 4.2 or
   4.0.14+ for maximum benefit, and is used in the RTIR 3.0 release

0.31 2013-04-08
 - Use the DatabaseAdmin configuration if supplied
 - Install /static/ on future 4.2 versions of RT

0.30 2012-11-06
 - remove a lot of old unused code
 - add support for a 4.1 feature that records database changes made by the