./graphics/p5-Barcode-Code128, Generate CODE 128 bar codes

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.21nb1, Package name: p5-Barcode-Code128-2.21nb1, Maintainer: pkgsrc-users

Barcode::Code128 generates bar codes using the CODE 128 symbology. It can
generate images in PNG or GIF format using the GD package, or it can generate a
text string representing the barcode that you can render using some other
technology if desired.

The intended use of this module is to create a web page with a bar code on it,
which can then be printed out and faxed or mailed to someone who will scan the
bar code. The application which spurred its creation was an expense report tool,
where the employee submitting the report would print out the web page and staple
the receipts to it, and the Accounts Payable clerk would scan the bar code to
indicate that the receipts were received.

The default settings for this module produce a large image that can safely be
FAXed several times and still scanned easily. If this requirement is not
important you can generate smaller image using optional parameters.

If you wish to generate images with this module you must also have the GD.pm
module (written by Lincoln Stein, and available from CPAN) installed.

If the GD module is not present, you can still use the module, but you will not
be able to use its functions for generating images. You can use the barcode()
method to get a string of "#" and " " (hash and space) characters, and use your
own image-generating routine with that as input.


Required to run:
[lang/perl5]

Master sites: (Expand)

SHA1: 1c49601039ceffd542beb2352004026481463704
RMD160: fae11114029995ca595d519770ba7b53becfb854
Filesize: 14.729 KB

Version history: (Expand)


CVS history: (Expand)


   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2016-02-16 15:41:23 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Update 2.01 to 2.21
-------------------
2.20  Tue Mar 29 11:51:38 CDT 2011
        - Fixed tests to avoid failures, upgrade tests to Test::More
          (courtesy Mark A. Stratman <stratman@gmail.com>)
        - Remove conditional support for GIF/PNG as all new versions
          since 2004 of GD should support both

2.21  Mon Sep 24 12:10:29 PDT 2012
        - Redesign tests to use Test::More and to be more tolerant of
          how different versions of GD encode images
          (thanks to Lukas Mueller <lam87@cornell.edu>)
        - Add PREREQ_PM to Makefile.PL
   2015-11-03 22:34:36 by Alistair G. Crooks | Files touched by this commit (610)
Log message:
Add SHA512 digests for distfiles for graphics category

Problems found with existing digests:
	Package fotoxx distfile fotoxx-14.03.1.tar.gz
	ac2033f87de2c23941261f7c50160cddf872c110 [recorded]
	118e98a8cc0414676b3c4d37b8df407c28a1407c [calculated]
	Package ploticus-examples distfile ploticus-2.00/plnode200.tar.gz
	34274a03d0c41fae5690633663e3d4114b9d7a6d [recorded]
	da39a3ee5e6b4b0d3255bfef95601890afd80709 [calculated]

Problems found locating distfiles:
	Package AfterShotPro: missing distfile AfterShotPro-1.1.0.30/AfterShotPro_i386.deb
	Package pgraf: missing distfile pgraf-20010131.tar.gz
	Package qvplay: missing distfile qvplay-0.95.tar.gz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.
   2013-05-31 14:42:58 by Thomas Klausner | Files touched by this commit (2880)
Log message:
Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.
   2012-10-06 16:11:27 by Aleksej Saushev | Files touched by this commit (427)
Log message:
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
   2012-10-03 23:59:10 by Thomas Klausner | Files touched by this commit (2798)
Log message:
Bump all packages that use perl, or depend on a p5-* package, or
are called p5-*.

I hope that's all of them.