./graphics/p5-GD-SecurityImage, Perl5 security image (CAPTCHA) generator

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.73nb2, Package name: p5-GD-SecurityImage-1.73nb2, Maintainer: pkgsrc-users

The (so called) "Security Images" are so popular. Most internet
software use these in their registration screens to block robot
programs (which may register tons of fake member accounts). Security
images are basicaly, graphical CAPTCHAs (Completely Automated Public
Turing Test to Tell Computers and Humans Apart). This module gives
you a basic interface to create such an image. The final output is
the actual graphic data, the mime type of the graphic and the
created random string. The module also has some "styles" that are
used to create the background (or foreground) of the image.

If you are an Authen::Captcha user, see GD::SecurityImage::AC for
migration from Authen::Captcha to GD::SecurityImage.

This module is just an image generator. Not a captcha handler. The
validation of the generated graphic is left to your programming
taste. But there are some captcha handlers for several Perl
FrameWorks. If you are an user of one of these frameworks, see
"GD::SecurityImage Implementations" in "SEE ALSO" section for
information.


Required to run:
[graphics/p5-GD] [graphics/p5-PerlMagick] [lang/perl5]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

SHA1: bf979a78352735a2044f838c8cd2292a00699027
RMD160: 20a1db00b110f2db34f19932b1e7792e8e74c2ae
Filesize: 86.438 KB

Version history: (Expand)


CVS history: (Expand)


   2017-06-09 18:43:16 by Ryo ONODERA | Files touched by this commit (4)
Log message:
Fix build with Perl 5.26.0
   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2016-02-17 04:32:50 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Update to 1.73
--------------
1.73 Wed Jan 21 01:36:45 2015
    => RT#87918.
   2015-11-03 22:34:36 by Alistair G. Crooks | Files touched by this commit (610)
Log message:
Add SHA512 digests for distfiles for graphics category

Problems found with existing digests:
	Package fotoxx distfile fotoxx-14.03.1.tar.gz
	ac2033f87de2c23941261f7c50160cddf872c110 [recorded]
	118e98a8cc0414676b3c4d37b8df407c28a1407c [calculated]
	Package ploticus-examples distfile ploticus-2.00/plnode200.tar.gz
	34274a03d0c41fae5690633663e3d4114b9d7a6d [recorded]
	da39a3ee5e6b4b0d3255bfef95601890afd80709 [calculated]

Problems found locating distfiles:
	Package AfterShotPro: missing distfile AfterShotPro-1.1.0.30/AfterShotPro_i386.deb
	Package pgraf: missing distfile pgraf-20010131.tar.gz
	Package qvplay: missing distfile qvplay-0.95.tar.gz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2014-10-09 15:45:06 by Thomas Klausner | Files touched by this commit (456)
Log message:
Remove SVR4_PKGNAME, per discussion on tech-pkg.
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.