./graphics/ruby-gnuplot, Ruby interface to a gnuplot process

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.6.2, Package name: ruby200-gnuplot-2.6.2, Maintainer: minskim

Ruby Gnuplot is a pipe-based interface to the gnuplot package. It
provides the full capabilities of the gnuplot package to Ruby
programs.


Required to run:
[lang/ruby200-base]

Master sites:

SHA1: b80e0b99d1af8029a45bdf3e87fc40462b3f0ff9
RMD160: a27ad1ae37d7499a9e996ba96a8c51b6b0166f4c
Filesize: 13.5 KB

Version history: (Expand)


CVS history: (Expand)


   2015-11-03 22:34:36 by Alistair G. Crooks | Files touched by this commit (610)
Log message:
Add SHA512 digests for distfiles for graphics category

Problems found with existing digests:
	Package fotoxx distfile fotoxx-14.03.1.tar.gz
	ac2033f87de2c23941261f7c50160cddf872c110 [recorded]
	118e98a8cc0414676b3c4d37b8df407c28a1407c [calculated]
	Package ploticus-examples distfile ploticus-2.00/plnode200.tar.gz
	34274a03d0c41fae5690633663e3d4114b9d7a6d [recorded]
	da39a3ee5e6b4b0d3255bfef95601890afd80709 [calculated]

Problems found locating distfiles:
	Package AfterShotPro: missing distfile AfterShotPro-1.1.0.30/AfterShotPro_i386.deb
	Package pgraf: missing distfile pgraf-20010131.tar.gz
	Package qvplay: missing distfile qvplay-0.95.tar.gz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-09-26 17:06:26 by Takahiro Kambe | Files touched by this commit (1) | Package updated
Log message:
Update HOMEPAGE.
Avoid using rubyforge.org since it stopped most of services.
   2013-01-14 07:14:04 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
Update ruby-gnuplot to 2.6.2.

2.6.2
* llrt: Make SPlot.to_gplot use parent's implementation

2.6.1
* TheKnight 	Fix bug in SPlot.to_gplot implementation.
   2012-12-17 13:21:15 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
Update ruby-gnuplot to 2.6.0.

2.6.0
* better readme, allow for unsetting variables, thanks @kot-behemoth and @evnu
   2012-09-16 08:36:08 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
Update ruby-gnuplot to 2.5.0.

2.5.0
 * save output to instance variable, thanks for the patch.
   2012-03-21 16:42:24 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-gnuplot to 2.4.1.

2.4.1
 * Quote escape more strings. Thanks for the tip!

2.4.0
 * Allow for 3D plots, fix examples. Thanks everybody!
   2011-06-19 03:37:30 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-gnuplot pakage to 2.3.6.

2.3.6
 * Cleanup readme (thanks blambeau again, really, for the snippets)

2.3.5
 * Cleanup readme, add examples as real code files (thanks blambeau!)
   2010-09-10 08:47:43 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update graphics/ruby-gnuplot to 2.3.4.

* Use lang/ruby/gem.mk instead of misc/rubygems/rubygem.mk.
* Add LICENSE.
* Remove default value of GEM_BUILD.

2.3.4
 * Include more files in the gem by switching to Jeweler (thanks Jeweler guyz)!

2.3.3
 * Fix issue #4 (thanks Jakobs)
 * Fix some unit tests (thanks Nobu!)

2.3.2 Feb 2010
 * Add an arbitrary_lines specifier

2.3.1 Feb 2010

* Fix a bug I introduced in 2.3.0

2.3.0 Feb 2010

* incorporate a few patch changes

2.2.3.1 July 18 2009

* output the raw "to gnuplot" data if $VERBOSE

Version 2.2.2 July 2009

* raise if no executable found, should be windows compat. now