./graphics/ruby-opengl, Ruby bindings for OpenGL, GLU and GLUT

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.60.1nb3, Package name: ruby22-opengl-0.60.1nb3, Maintainer: taca

ruby-opengl consists of Ruby extension modules that are bindings for
the OpenGL, GLU, and GLUT libraries. It is intended to be a replacement
for -- and uses the code from -- Yoshi's ruby-opengl.


Required to run:
[graphics/glut] [graphics/MesaLib] [graphics/glu] [devel/ruby-mkrf] [lang/ruby22-base]

Required to build:
[pkgtools/x11-links] [x11/glproto] [x11/xproto] [x11/xf86vidmodeproto] [x11/xf86driproto] [x11/damageproto] [x11/inputproto] [x11/xextproto] [x11/dri2proto] [x11/fixesproto4]

Master sites:

SHA1: ae8a2ceec7102fce6450273885372fa16d820c87
RMD160: fc046485ad0da0a269c5b282cef9f027dad16077
Filesize: 239.5 KB

Version history: (Expand)


CVS history: (Expand)


   2016-05-26 19:08:57 by Takahiro Kambe | Files touched by this commit (5) | Package updated
Log message:
Fix rpath provlem with native X11.

Bump PKGREVISION.
   2015-11-03 22:34:36 by Alistair G. Crooks | Files touched by this commit (610)
Log message:
Add SHA512 digests for distfiles for graphics category

Problems found with existing digests:
	Package fotoxx distfile fotoxx-14.03.1.tar.gz
	ac2033f87de2c23941261f7c50160cddf872c110 [recorded]
	118e98a8cc0414676b3c4d37b8df407c28a1407c [calculated]
	Package ploticus-examples distfile ploticus-2.00/plnode200.tar.gz
	34274a03d0c41fae5690633663e3d4114b9d7a6d [recorded]
	da39a3ee5e6b4b0d3255bfef95601890afd80709 [calculated]

Problems found locating distfiles:
	Package AfterShotPro: missing distfile AfterShotPro-1.1.0.30/AfterShotPro_i386.deb
	Package pgraf: missing distfile pgraf-20010131.tar.gz
	Package qvplay: missing distfile qvplay-0.95.tar.gz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-07 12:50:27 by Takahiro Kambe | Files touched by this commit (2)
Log message:
Use more modern macro to build with newer Ruby.
   2015-04-25 16:23:48 by Tobias Nygren | Files touched by this commit (868) | Package updated
Log message:
Recursive revbump following MesaLib update, categories g through n.
   2015-03-08 17:49:18 by Takahiro Kambe | Files touched by this commit (1)
Log message:
Add ${GEM_EXTSDIR}/gem.build_complete.
   2014-03-25 17:34:50 by Takahiro Kambe | Files touched by this commit (1)
Log message:
Fix build with ruby21.
   2014-03-17 15:14:18 by Takahiro Kambe | Files touched by this commit (1)
Log message:
Add GEM_EXTSDIR support and utilize GEM_NAME.
   2013-03-07 18:05:42 by Takahiro Kambe | Files touched by this commit (2)
Log message:
Fix build problem with ruby18-base, using modern rules from rubygems
and class.