"Obsolete package, no longer supported by OCaml 4.09"
./lang/camlp4, Preprocessor and pretty printer for OCaml

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 4.08+1, Package name: camlp4-4.08+1, Maintainer: jaapb

Camlp4 is a software system for writing extensible parsers for programming
languages. It provides a set of OCaml libraries that are used to define
grammars as well as loadable syntax extensions of such grammars. Camlp4 stands
for Caml Preprocessor and Pretty-Printer and one of its most important
applications is the definition of domain-specific extensions of the syntax of
OCaml.

This package is obsolete and no longer supported by OCaml 4.09 and over.
Users should switch to the new PPX infrastructure or use Camlp5.


Required to run:
[lang/ocaml]

Required to build:
[pkgtools/cwrappers] [devel/ocamlbuild]

Master sites:

SHA1: 7cf80c5b340fcee29d00034003e66648fc66cc3e
RMD160: d165eb98c8c2aae2f0b2b5102384d61de3243a5d
Filesize: 634.6 KB

Version history: (Expand)


CVS history: (Expand)


   2020-01-17 10:44:32 by Jaap Boender | Files touched by this commit (2)
Log message:
Marked lang/camlp4 as BROKEN.

Added a note to DESCR: this package is obsolete and users should switch
to camlp5 or use ppx.
   2019-11-03 20:04:09 by Roland Illig | Files touched by this commit (159)
Log message:
lang: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

No manual corrections.
   2019-10-09 10:57:14 by SAITOH Masanobu | Files touched by this commit (2) | Package updated
Log message:
 Update campl4 to 4.08+1.

This is due to the upgrade of lang/ocaml to 4.08 - camlp4 has to follow
suit.
   2018-11-12 17:10:29 by Jaap Boender | Files touched by this commit (141) | Package updated
Log message:
Revbumps associated with update of lang/ocaml.
   2018-07-19 14:18:03 by Jaap Boender | Files touched by this commit (3) | Package updated
Log message:
Updated lang/camlp4 to version 4.07+1.

This is a maintenance release, only meant for compatibility with OCaml
4.07.
   2018-04-13 15:55:39 by Jaap Boender | Files touched by this commit (88)
Log message:
Revbump associated with the upgrade of lang/ocaml

(this is the upgrade from 4.06 to 4.06.1)
   2018-01-10 17:22:41 by Jaap Boender | Files touched by this commit (3) | Package updated
Log message:
Updated package lang/camlp4 to version 4.06+1.

This is due to the upgrade of lang/ocaml to 4.06 - camlp4 has to follow
suit.
   2017-09-08 13:31:01 by Jaap Boender | Files touched by this commit (3) | Package updated
Log message:
Updated package to latest version, 4.05. A changelog is not available -
this is a minor release that fixes compatibility with OCaml 4.05, though.