./mail/imp, Internet Messaging Program

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 4.3.11nb2, Package name: imp-4.3.11nb2, Maintainer: pkgsrc-users

IMP is a set of PHP scripts that implement an IMAP/POP based webmail system.
Assuming you have an account on a server that supports IMAP/POP, you can use
an installation of IMP to check your mail from anywhere that you have web
access.


Required to run:
[www/horde] [mail/php-imap] [mail/pear-Mail] [mail/pear-Mail_mimeDecode]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: f871360d3cb0e6964ab50c4797ef0133beabed46
RMD160: f8280293b792ee7b9f12545707af1353e9e4fbe2
Filesize: 5446.086 KB

Version history: (Expand)


CVS history: (Expand)


   2017-01-19 19:52:30 by Alistair G. Crooks | Files touched by this commit (352)
Log message:
Convert all occurrences (353 by my count) of

	MASTER_SITES= 	site1 \
			site2

style continuation lines to be simple repeated

	MASTER_SITES+= site1
	MASTER_SITES+= site2

lines. As previewed on tech-pkg. With thanks to rillig for fixing pkglint
accordingly.
   2016-12-01 15:48:02 by Thomas Klausner | Files touched by this commit (9)
Log message:
Fix weird CONFLICTS line.
   2016-09-11 19:03:29 by Takahiro Kambe | Files touched by this commit (53)
Log message:
Drop "55" (php55) from PHP_VERSIONS_ACCEPTED.
   2016-05-17 12:32:09 by Filip Hajny | Files touched by this commit (36)
Log message:
Use REAL_ROOT_USER/REAL_ROOT_GROUP instead of ROOT_USER/ROOT_GROUP
for all pkgsrc dir/file ownership rules. Fixes unprivileged
user/group names from leaking into binary packages, manifest as
non-fatal chown/chgrp failure messages at pkg_add time.

Bump respective packages' PKGREVISION.
   2015-12-19 15:27:15 by Takahiro Kambe | Files touched by this commit (26)
Log message:
Restrict PHP_VERSIONS_ACCEPTED to 55 and 56.
   2015-11-04 00:27:24 by Alistair G. Crooks | Files touched by this commit (312)
Log message:
Add SHA512 digests for distfiles for mail category

Problems found locating distfiles:
	Package mutt: missing distfile patch-1.5.24.rr.compressed.gz
	Package p5-Email-Valid: missing distfile Email-Valid-1.198.tar.gz
	Package pine: missing distfile fancy.patch.gz
	Package postgrey: missing distfile targrey-0.31-postgrey-1.34.patch
	Package qmail: missing distfile badrcptto.patch
	Package qmail: missing distfile outgoingip.patch
	Package qmail: missing distfile qmail-1.03-realrcptto-2006.12.10.patch
	Package qmail: missing distfile qmail-smtpd-viruscan-1.3.patch
	Package thunderbird24: missing distfile enigmail-1.7.2.tar.gz
	Package thunderbird31: missing distfile enigmail-1.7.2.tar.gz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2013-03-16 08:21:26 by OBATA Akio | Files touched by this commit (45) | Package updated
Log message:
Bump PKGREVISION from default PHP version change to 5.4.
   2012-02-23 12:04:09 by OBATA Akio | Files touched by this commit (2) | Package updated
Log message:
Update imp to 4.3.11.
(while here, set LICENSE=gnu-gpl-v2.)

-------
v4.3.11
-------

[mms] SECURITY: Fix XSS vulnerabilities on the compose page, the contacts popup
      window, and with certain IMAP mailbox names.

-------
v4.3.10
-------

[jan] Don't submit the action form when reloading messages with iTip
      attachments (Bug #9502).