./misc/ruby-ansi, Collection of ANSI escape code related libraries

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.5.0, Package name: ruby23-ansi-1.5.0, Maintainer: pkgsrc-users

The ANSI project is a collection of ANSI escape code related libraries
enabling ANSI code based colorization and stylization of output.
It is very nice for beautifying shell output.


Required to run:
[lang/ruby23-base]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: fa9e40d63308b9ab61d1aca24dff3ec36581d619
RMD160: 2cfffcc6030d7e7b01d1fa912f7045b34e990018
Filesize: 40.5 KB

Version history: (Expand)


CVS history: (Expand)


   2015-11-04 00:49:56 by Alistair G. Crooks | Files touched by this commit (330)
Log message:
Add SHA512 digests for distfiles for misc category

Problems found locating distfiles:
	Package colorls: missing distfile ls.tar.gz
	Package molden: missing distfile molden-4.6/molden4.6.tar.gz
	Package softmaker-office-demo: missing distfile ofl06trial.tgz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-02-03 15:48:08 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-ansi to 1.5.0.

## 1.5.0 | 2015-01-16

ANSI 1.5 introduces one change that is not backward compatiable. The
`:clear_line` code no longer clears to the end of the line. Instead it
clears the entire line. If you have used this in the past you
will need to update your code to use `:clear_eol` or `:clear_right`
instead. In addition this release finally fixes some long time issues
with Windows compatability, and a few other bugs. Yeah!

Changes:

* Alias `:right` and `:left` as `:forward` and `:back` respectively.
* Change `:clear_line` to clear whole line, not just to the end of line.
* Add `:cursor_hide` and `:cursor_show` codes.
* Fix and adjust #rgb method to work as one would expect.
* Fix Windows compatability (old code was alwasy using stty).
* Fix duplicated hash key in chart.rb.
   2012-09-16 08:43:30 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-ansi to 1.4.3.

== 1.4.3 | 2012-06-26

This release bring two small changes. The first improves support
for Windows by only rescuing LoadError when 'win32console' fails
to load. The second improves the heuritstics used for determining
the current terminal screen width.

Changes:

* Only rescue LoadError on windows require. (#9) [bug]
* Improvements for getting proper screen width.
   2012-03-01 16:10:40 by Takahiro Kambe | Files touched by this commit (4) | Imported package
Log message:
Importing ruby-ansi package version 1.4.2.