./misc/ruby-transaction-simple, Mixin library for adding transaction support to objects

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.4.0.2, Package name: ruby23-transaction-simple-1.4.0.2, Maintainer: pkgsrc-users

Transaction::Simple provides a generic way to add active transaction
support to objects. The transaction methods added by this module will
work with most objects, excluding those that cannot be Marshal-ed
(bindings, procedure objects, IO instances, or singleton objects).


Required to run:
[lang/ruby23-base]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 73783842fdcaea2a7bd61f2981c8372a45048136
RMD160: 18cef0f36100fc4a45960e57540c78366a4d0609
Filesize: 17 KB

Version history: (Expand)


CVS history: (Expand)


   2015-11-04 00:49:56 by Alistair G. Crooks | Files touched by this commit (330)
Log message:
Add SHA512 digests for distfiles for misc category

Problems found locating distfiles:
	Package colorls: missing distfile ls.tar.gz
	Package molden: missing distfile molden-4.6/molden4.6.tar.gz
	Package softmaker-office-demo: missing distfile ofl06trial.tgz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-09-26 17:10:21 by Takahiro Kambe | Files touched by this commit (1)
Log message:
Avoid using rubyforge.org since it stopped most of services.
   2012-09-16 08:47:39 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-transaction-simple to 1.4.0.2.

== 1.4.0.2 / 2012-06-20
* Bookkeeping release that fixes install in scenarios where the RubyGem
  indicated it had a runtime dependency on hoe. Thanks to Michael Grosser
  (https://github.com/grosser) for the inspiration.
* Marked all files as UTF-8.

== 1.4.0.1 / 2007-10-01
* Fixed a simple bug with the #transaction method handling.
   2011-08-12 19:04:45 by Takahiro Kambe | Files touched by this commit (1) | Package updated
Log message:
Add dependency to hoe package due to rubygems.

Bump PKGREVISION.
   2010-09-10 09:26:51 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
* Use lang/ruby/gem.mk instead of misc/rubygems/rubygem.mk.
* Add LICENSE.
* Ajust new ruby package's framework.
* Update dependency according to gemspec.

Bump PKGREVISION.
   2009-06-14 20:07:32 by Joerg Sonnenberger | Files touched by this commit (129)
Log message:
Remove @dirrm entries from PLISTs
   2008-08-15 18:07:16 by Takahiro Kambe | Files touched by this commit (1)
Log message:
Add RubyForge's project page as HOMEPAGE.