./multimedia/adobe-flash-player, Adobe Flash Player Browser NPAPI plugin

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 25.0.0.171, Package name: adobe-flash-player-25.0.0.171, Maintainer: tsutsui

NPAPI Adobe Flash player plugin for the Firefox browser.
This package contains a plugin that enables web browsers to render
the Flash format.

The nspluginwrapper option (enabled by default on non Linux platforms)
permits the use of the the Linux x86 and x86_64 flash player in Firefox
browsers on other x86 systems and x86_64 systems.

For NetBSD this package requires NetBSD 6.2 or 7.1 (and later versions)
which include procfs fixes for Linux binaries.

MESSAGE.pulseaudio [+/-]

Required to run:
[www/nspluginwrapper] [multimedia/libflashsupport] [emulators/suse121_krb5] [emulators/suse121_glx] [emulators/suse121_alsa] [emulators/suse121_libcurl] [emulators/suse121_base] [emulators/suse121_x11] [emulators/suse121_gtk2]

Required to build:
[pkgtools/cwrappers]

Package options: nspluginwrapper

Master sites:


Version history: (Expand)


CVS history: (Expand)


   2017-05-13 06:11:46 by Izumi Tsutsui | Files touched by this commit (2) | Package updated
Log message:
Update adobe-flash-player to 25.0.0.171.

Upstream announcements:

 https://helpx.adobe.com/security/produc … 17-15.html

Security updates available for Adobe Flash Player

Release date: May 9, 2017

Vulnerability identifier: APSB17-15

CVE number: CVE-2017-3068, CVE-2017-3069, CVE-2017-3070, CVE-2017-3071,
 CVE-2017-3072, CVE-2017-3073, CVE-2017-3074

Platform: Windows, Macintosh, Linux and Chrome OS
   2017-04-12 17:31:13 by Izumi Tsutsui | Files touched by this commit (2) | Package updated
Log message:
Update adobe-flash-player to 25.0.0.148.

Upstream announcements:

 https://helpx.adobe.com/security/produc … 17-10.html

Adobe Security Bulletin

Security updates available for Adobe Flash Player

Release date: April 11, 2017

Vulnerability identifier: APSB17-10

CVE number: CVE-2017-3058, CVE-2017-3059, CVE-2017-3060, CVE-2017-3061,
 CVE-2017-3062, CVE-2017-3063, CVE-2017-3064

Platform: Windows, Macintosh, Linux and Chrome OS
   2017-03-17 23:11:12 by Izumi Tsutsui | Files touched by this commit (2) | Package updated
Log message:
Update adobe-flash-player to 25.0.0.127.

Upstream announcements:

 https://helpx.adobe.com/security/produc … 17-07.html

Security updates available for Adobe Flash Player

Release date: March 14, 2017

Vulnerability identifier: APSB17-07

CVE number: CVE-2017-2997, CVE-2017-2998, CVE-2017-2999, CVE-2017-3000,
 CVE-2017-3001, CVE-2017-3002, CVE-2017-3003

Platform: Windows, Macintosh, Linux and Chrome OS
   2017-03-17 22:56:29 by Izumi Tsutsui | Files touched by this commit (7) | Package updated
Log message:
Re-import multimedia/adobe-flash-player24 as multimedia/adobe-flash-player
for future major version bump with compatibility.

We had multiple adobe-flash-plugin versions in the past because
newer 11.x versions didn't work on older (4.x) NetBSD systems.
However I guess Adobe will not put aggressive changes that require
newer Linux kernel version (i.e. emul.linux.kern.osrelease on NetBSD)
in future periodical major updates, as per their announcements:
 https://blogs.adobe.com/flashplayer/201 … linux.html
> Because this change is primarily a security initiative, some features
> (like GPU 3D acceleration and premium video DRM) will not be fully
> implemented.

No objection on pkgsrc-users@:
 http://mail-index.netbsd.org/pkgsrc-use … 24523.html
Also ok'ed by gdt@ in private mail.

---

NPAPI Adobe Flash player plugin for the Firefox browser.
This package contains a plugin that enables web browsers to render
the Flash format.

The nspluginwrapper option (enabled by default on non Linux platforms)
permits the use of the the Linux x86 and x86_64 flash player in Firefox
browsers on other x86 systems and x86_64 systems.

For NetBSD this package requires NetBSD 6.2 or 7.1 (and later versions)
which include procfs fixes for Linux binaries.