./multimedia/gnash, GPL SWF player

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.8.10nb59, Package name: gnash-0.8.10nb59, Maintainer: pkgsrc-users

Gnash is a player for animated "movies" in the Macromedia Shockwave Flash
(.swf) format. It can be run as a graphical application, as a Web browser
plugin, or as a library used by other programs. It is not yet complete;
it does not correctly handle every .swf file.

Many of the Flash movies that I come across play fine in Gnash. Many
others do not. In particular, Flash movies that are used for browser
navigation may still have a few issues with some URLs left. Most
Flash based navigation of a web site should work.

Gnash supports the majority of Flash opcodes up to SWF version 7, and
a wide sampling of ActionScript classes for SWF version 7. All the core
ones are implemented, and many of the newer ones work, but may be missing
some of their methods. All unimplemented opcodes and ActionScript classes
and methods print a warning when using -v with gnash or gprocessor. Using
gprocessor -v is a quick way to see why a movie isn't playing correctly.


Required to run:
[sysutils/desktop-file-utils] [www/curl] [graphics/hicolor-icon-theme] [graphics/png] [graphics/jpeg] [multimedia/gst-plugins0.10-base] [multimedia/gst-plugins0.10-ffmpeg] [multimedia/gstreamer0.10] [audio/speex] [audio/gst-plugins0.10-mad] [audio/gst-plugins0.10-vorbis] [fonts/Xft2] [devel/boost-libs] [devel/SDL] [devel/libltdl] [x11/gtk2] [x11/libXv] [graphics/agg] [graphics/giflib] [devel/pangox-compat]

Required to build:
[pkgtools/x11-links] [devel/boost-headers] [x11/xcb-proto] [x11/fixesproto4] [devel/npapi-sdk] [pkgtools/cwrappers] [x11/xorgproto]

Package options: agg, gstreamer, gtk

Master sites: (Expand)

SHA1: be3b12a5edcd3b05f2ae73d02f0991aa786e7300
RMD160: 0093174ec0a912309772c033b5f1c1ad46ab41dc
Filesize: 4138.775 KB

Version history: (Expand)


CVS history: (Expand)


   2018-08-16 20:55:17 by Adam Ciarcinski | Files touched by this commit (653) | Package updated
Log message:
revbump after boost-libs update
   2018-04-29 23:32:09 by Adam Ciarcinski | Files touched by this commit (629) | Package updated
Log message:
revbump for boost-libs update
   2018-04-16 16:35:28 by Thomas Klausner | Files touched by this commit (1284)
Log message:
Recursive bump for new fribidi dependency in pango.
   2018-03-12 12:18:01 by Thomas Klausner | Files touched by this commit (2155)
Log message:
Recursive bumps for fontconfig and libzip dependency changes.
   2018-02-26 09:19:32 by Adam Ciarcinski | Files touched by this commit (89) | Package updated
Log message:
revbump after x264-devel update
   2018-01-01 23:30:04 by Roland Illig | Files touched by this commit (537)
Log message:
Sort PLIST files.

Unsorted entries in PLIST files have generated a pkglint warning for at
least 12 years. Somewhat more recently, pkglint has learned to sort
PLIST files automatically. Since pkglint 5.4.23, the sorting is only
done in obvious, simple cases. These have been applied by running:

  pkglint -Cnone,PLIST -Wnone,plist-sort -r -F
   2018-01-01 22:18:57 by Adam Ciarcinski | Files touched by this commit (629) | Package updated
Log message:
Revbump after boost update
   2017-09-27 15:37:28 by Thomas Klausner | Files touched by this commit (1)
Log message:
gnash: add missing .endif

Remove duplicate devel/SDL/bl3.mk inclusion that confused pkglint.