NOTICE: This package has been removed from pkgsrc

./multimedia/vlc20, VLC media player and streaming server

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ]


Branch: CURRENT, Version: 2.0.9nb39, Package name: vlc-2.0.9nb39, Maintainer: pkgsrc-users

VideoLAN is a project of French students from the Ecole Centrale Paris
and developers from all over the world. Its main goals is MPEG streaming
on a network, but it also features a standalone multimedia player. The
VideoLAN Server can stream video read from a hard disk, a DVD player,
a satellite card or an MPEG 2 compression card, and unicast or multicast
it on a network. The VideoLAN Client can read the stream from the network
and display it. It can also be used to display video read locally on
the computer : DVDs, VCDs, MPEG and DivX files and from a satellite
card. It is multi-plaform : Linux, Windows, Mac OS X, BeOS, BSD, Solaris,
QNX, iPaq... The VideoLAN Client and Server now have a full IPv6 support.

This version is the last version with support for OSSv3, which is the
OSS version implemented in NetBSD before NetBSD 7.


Required to run:
[sysutils/desktop-file-utils] [textproc/libxml2] [converters/fribidi] [misc/libcdio] [graphics/MesaLib] [graphics/hicolor-icon-theme] [graphics/freetype2] [graphics/png] [graphics/glu] [multimedia/libmpeg2] [multimedia/libdvdnav] [multimedia/libmatroska] [multimedia/libogg] [multimedia/libdvdplay] [multimedia/x264-devel] [multimedia/libdvdread] [multimedia/libtheora] [audio/libid3tag] [audio/flac] [audio/liba52] [audio/libvorbis] [audio/libmad] [audio/libcddb] [audio/taglib] [audio/faad2] [fonts/dejavu-ttf] [net/libupnp] [security/gnutls] [security/libgcrypt] [devel/libebml] [devel/pcre] [x11/libXdamage] [x11/libXvMC] [x11/qt4-libs] [x11/libXv] [x11/libXpm] [x11/libxcb] [multimedia/libva] [x11/xcb-util-keysyms] [multimedia/libdvbpsi0] [audio/musepack] [multimedia/ffmpeg1]

Required to build:
[pkgtools/x11-links] [devel/gettext-tools] [x11/xcb-proto] [x11/fixesproto4] [pkgtools/cwrappers] [x11/xorgproto]

Package options: faad, vaapi, x11

Master sites:

SHA1: d82131914023fff2a414859228a38fcc19ab59d9
RMD160: cbdac7bfb9375c2d0de159d063cc27a6969da649
Filesize: 18420.918 KB

Version history: (Expand)


CVS history: (Expand)


   2018-04-25 23:42:05 by Kamil Rytarowski | Files touched by this commit (30) | Package removed
Log message:
vlc20: Removed

This is a legacy version of VLC 2.0.x.

Reasons:
 - It uses FFMPEG 2.x with old OpenSSL.
 - It uses legacy x264 incompatible with the pkgsrc one.

There is a newer version multimedia/vlc for 2.2.x and 3.0.x released
upstream.
   2018-04-18 00:29:53 by Thomas Klausner | Files touched by this commit (286)
Log message:
Add p11-kit to gnutls/bl3.mk and bump dependencies.
   2018-04-16 16:35:28 by Thomas Klausner | Files touched by this commit (1284)
Log message:
Recursive bump for new fribidi dependency in pango.
   2018-03-12 12:18:01 by Thomas Klausner | Files touched by this commit (2155)
Log message:
Recursive bumps for fontconfig and libzip dependency changes.
   2018-02-26 09:19:32 by Adam Ciarcinski | Files touched by this commit (89) | Package updated
Log message:
revbump after x264-devel update
   2018-01-28 21:11:10 by Thomas Klausner | Files touched by this commit (462) | Package updated
Log message:
Bump PKGREVISION for gdbm shlib major bump
   2017-11-23 18:20:22 by Thomas Klausner | Files touched by this commit (556)
Log message:
recursive bump for libxkbcommon removal from at-spi2-core
   2017-09-08 04:38:46 by Ryo ONODERA | Files touched by this commit (132)
Log message:
Recursive revbump from audio/pulseaudio-11.0