./net/net6, Networking library for C++

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.3.14nb3, Package name: net6-1.3.14nb3, Maintainer: pkgsrc-users

net6 is a library which eases the development of network-based
applications as it provides a TCP protocol abstraction for C++. It is
portable to both the Windows and Unix-like platforms.


Required to run:
[security/gnutls] [devel/libsigc++]

Required to build:
[lang/gcc48] [pkgtools/cwrappers]

Master sites:

SHA1: 7523a604e6b7f723cdd7f457f8f7c8c9cf48dae1
RMD160: c1445cdf2e7a34d0639d7bb410404d83ab972d27
Filesize: 472.216 KB

Version history: (Expand)


CVS history: (Expand)


   2017-05-03 10:38:46 by Jonathan Perkin | Files touched by this commit (95)
Log message:
Convert CXXFLAGS setting C++ standard to USE_LANGUAGES.
   2016-09-26 03:08:42 by Kamil Rytarowski | Files touched by this commit (3) | Package updated
Log message:
Fix net/net6 build against new GnuTLS

Patch inspired by net/vino/patches/patch-server_libvncserver_auth.c (r.1.1)

Bump PKGREVISION to 3.
   2016-09-19 15:04:29 by Thomas Klausner | Files touched by this commit (147)
Log message:
Recursive PKGREVISION bump for gnutls shlib major bump.
   2015-11-04 01:35:47 by Alistair G. Crooks | Files touched by this commit (748)
Log message:
Add SHA512 digests for distfiles for net category

Problems found with existing digests:
	Package haproxy distfile haproxy-1.5.14.tar.gz
	159f5beb8fdc6b8059ae51b53dc935d91c0fb51f [recorded]
	da39a3ee5e6b4b0d3255bfef95601890afd80709 [calculated]

Problems found locating distfiles:
	Package bsddip: missing distfile bsddip-1.02.tar.Z
	Package citrix_ica: missing distfile citrix_ica-10.6.115659/en.linuxx86.tar.gz
	Package djbdns: missing distfile djbdns-1.05-test25.diff.bz2
	Package djbdns: missing distfile djbdns-cachestats.patch
	Package djbdns: missing distfile 0002-dnscache-cache-soa-records.patch
	Package gated: missing distfile gated-3-5-11.tar.gz
	Package owncloudclient: missing distfile owncloudclient-2.0.2.tar.xz
	Package poink: missing distfile poink-1.6.tar.gz
	Package ra-rtsp-proxy: missing distfile rtspd-src-1.0.0.0.tar.gz
	Package ucspi-ssl: missing distfile ucspi-ssl-0.70-ucspitls-0.1.patch
	Package waste: missing distfile waste-source.tar.gz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-10-20 11:40:22 by Tobias Nygren | Files touched by this commit (21)
Log message:
packages that use libsigc++ need -std=c++11 now

approved by wiz@
   2015-08-23 16:30:43 by Thomas Klausner | Files touched by this commit (125) | Package updated
Log message:
Bump PKGREVISION for nettle shlib major bump.
   2015-02-05 09:06:22 by Thomas Klausner | Files touched by this commit (1) | Package updated
Log message:
Remove patch-encrypt.cpp, removed from distinfo during 1.3.14 update.
   2015-01-29 03:59:27 by Makoto Fujiwara | Files touched by this commit (4) | Package updated
Log message:
(pkgsrc)
 - Add LICENSE as gnu-gpl-v2
 - delete patch for gnutls, upstream now takes care, although the boundary
   is little bit different as:
   (patch)    #if GNUTLS_VERSION_NUMBER < 0x020c00
   (upstream) #if GNUTLS_VERSION_NUMBER < 0x030003
 - Add comment on patch-src_select.cpp (from cvs log)

(upstream)
 - Update 1.3.10 to 1.3.14
Version 1.3.14:
 * Ensure that overflows on the user ID assigned to each connection
   do not yield one that is already in use.  (Reported by Vasiliy
   Kulikov.)  [CVE-2011-4093]
 * Do not leak information about logged-in users.  (Reported by
   Vasiliy Kulikov.)  [CVE-2011-4091]
 * Fix build failures with GnuTLS 3.0 and above, thanks to
   Vincent Untz.
 * Updated translations

Version 1.3.13:
 * Updated translations

Version 1.3.12:
 * Allow non-blocking sockets on *nix.
 * New translations:
   - Korean
   - English (Great Britain)

Version 1.3.11:
 * Fix possible TLS lockup on Windows.
 * New translation:
   - Ukrainian, thanks to Yuri Chornoivan!