./net/proftpd-postgresql, PostgreSQL module for ProFTPD

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.3.5d, Package name: proftpd-postgresql92-1.3.5d, Maintainer: kim

ProFTPD module that provides the PostgreSQL backend for SQL database
authentication.


Required to run:
[lang/perl5] [net/proftpd] [databases/postgresql92-client]

Required to build:
[pkgtools/cwrappers]

Package options: inet6, pam

Master sites: (Expand)

SHA1: e7271c9f6df331eda393a834ad66ff60eff134ca
RMD160: 2052a7c41824c8ce9558fd11c78843b1b07ab6e7
Filesize: 29264.219 KB

Version history: (Expand)


CVS history: (Expand)


   2017-04-05 19:36:00 by Kimmo Suominen | Files touched by this commit (5) | Package updated
Log message:
Update net/proftpd (and modules) to 1.3.5d with a fix for CVE-2017-7418

1.3.5d - Released 15-Jan-2017
--------------------------------
- Bug 4283 - All FTP logins treated as anonymous logins again.  This is a
  regression of Bug#3307.

1.3.5c - Released 14-Jan-2017
--------------------------------
- Bug 4254 - SSH rekey during authentication can cause issues with clients.
- Bug 4257 - Recursive SCP uploads of multiple directories not handled properly.
- Bug 4259 - LIST returns different results for file, depending on path syntax.
- Bug 4255 - "AuthAliasOnly on" in server config breaks anonymous logins.
- Bug 4272 - CapabilitiesEngine directive not honored for \ 
<IfUser>/<IfGroup>
  sections.
- Bug 4275 - Support OpenSSL 1.1.x API.
- Bug 4278 - Memory leak when mod_facl is used.
   2016-10-09 23:42:04 by Thomas Klausner | Files touched by this commit (110)
Log message:
Recursive bump for all users of pgsql now that the default is 95.